Skip to Content
author's profile photo Former Member
Former Member

ERROR: The procedure needs a patched version of R3trans which is build on 12.05.10 or later.

Hi,

I am upgrading from EHP5 for ERP 6.0 to EHP6 for ERP6.0 sp stack 03 using SUM.

I then get the error below in the extraction phase.

ERROR: The procedure needs a patched version of R3trans which is build on 12.05.10 or later.

The R3trans in your active SAP kernel is either older or the version could not be determined. Call it without any option to determine the build date.

If the build date is too old, you have to replace it before you can continue the procedure.

Download the latest executable available from the SAP Service Marketplace and update it before you continue.

Otherwise, the tools will be corrupted.

I gather this means I need to upgrade my kernel? I have never done that before, please give me steps on how to proceed.

Regards,

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jun 06, 2012 at 11:03 AM

    Hello,

    Yes, you must replace the kernel in your source system ie., /usr/sap/<SID>/SYS/exe/run

    with the latest kernel patch available in service market place.

    Also you must replace the kernel in your target ie., in /EHPI/abap/exe and /EHPI/abap/exenew

    folders.

    Please check the note:

    19466 - Downloading SAP kernel patches.

    This note will explain how to download the kernel patches and replace them in the above mentioned

    folders.

    (P.S- Your source system is EHP5, hence the kernel release would be 720.

    Target is EHP6, and the kernel release would be 720 here as well)

    Hope this information helps.

    Regards,

    Sandhya

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jun 06, 2012 at 11:16 AM

    Hello,

    Could you please check the versions of tp & r3trans in the following directories :

    1. ...SYS/exe/run

    2. DVEBMGS<nr>/exe

    3. ../abap/exe

    4. ../abapexenew

    check if the the build date is older then the 12.05.10 . If they are older then you need to update the tp & r3trans (Or kernel) to the latest..

    Sometimes this issue also happens if the environment variables are not defined properly and tool is not able to detect the version due to this. So also make sure if the environment variables are set correctly.

    hope the above information helps

    Regards,

    Varun

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.