Skip to Content

maxdb parameters for CAT_CACHE_SUPPLY ?? EWA Report yellow decrease

Hi there.

We drive a maxdb version 7.8.02.026 on a SLES 10 linux EP (64 bit) with 64 Gig RAM
with CI and DB Instcance on one Host. (No App Server) Kernel
7.00 Version 344

DB Settings:

Cache_size 1310720

Catalog-Cache 800.000

MaxUsertasks
50

Cat_Cache_Supply
100000

MaxCPU
4

MaxSQLLocks
600000

The data area is 400 GB

The Data Cache Hit Ratio = 99,32%

Catalog-Cache 83,45%

I have increased the CAT_CACHE_SUPPLY Parameter last week from 10316 to 10000
because the Hitratio was about 85%. A little bit too low related to EWA! Cache Hit Ratios gets
a yellow alert! Explan in EWA:

The performance of your database may decrease if the data cache hit
ratio is below 99% or the catalog cache hit ratio is below 86%. Differs from
sapnote 819641 - FAQ: SAP MaxDB Performance

I know that maxdb 7.8 was more memory consuming than 7.6, so i tryed to gets a bit more speed in the application.

On the development System with 32 GB the Ratio was also bad! Was the value 100 000
to BIG for CAT_CACHE_SUPPLY? Our Solution Manager with 18GB Ram and
CAT_CACHE_SUPPLY =300 000 gots a better hit Ratio from 84,23 %!

Could somebody give me advices for the next the next downtime on Friday 08.06.12??
Then we could restart the DB Instance and activate new parameters.

Please😉


















Are
there in addition some more parameters i have to change?

Any
help welcomed.

With
kind regards

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Jun 05, 2012 at 12:57 PM

    Hi Ralf,

    I know that the colleagues take care of the Catalog Cache hitrate. I think the low catalog cache hitrate is not important - why I think so.

    When there is no more free Catalog Cache page the used Catalog cache is swapped into the data Cache first. So the system is reading the data from cache anywhy.

    Should should take more attention to the data cache hitrate. If this hitrate is bad then the data is swapped to the disk. This causes IO when the data has to be read again from the disk into the Data Cache. IO should be avoided as much as possible.


    I recommend to run the parameter check of note 1111426 to be sure that the parameters are set correctly. And you can check the feature note of SAP MaxDb Version 7.8 if there are some performance issues known in 7.8.02.26 and already solved with 7.8.02.28.

    You can use the db-Analyzer tool to find the bottlenecks in your system, when the data cache hitrate is getting worse may be some SQL commands can be optimized with an additional index to reduce the number of data which has to be read to get the result. You will find information about how to start a performacne analysis in the MaxDb Expert Session which can be downloaded from http://maxdb.sap.com/training/ Session 4 performance Optimization MaxDb -> there is a recodring and the slides available to download

    Hope this will help to optimize your system. The Parameter setting for Cat_cache_Supply seems to be ok with 10000 pages.

    Regards,

    Christiane

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.