Skip to Content

No data found when execute ldap_read FM

Dear Experts,

I am having trouble reading data from LDAP server. When I run ldap_read function module with base entry as 'dc=domain, dc=com' and filter as (&(objectClass=*)) it returns all the entries, but when I search any user from that data I couldn't find any user.

When I chnaged base entry to 'OU=Accounts,dc=domain,dc=com' and filter as (&(objectClass=*)) it returns back the same base entry in the table with no data in the attributes table.

I tried running the find operation from ldap transaction, I got the same result as ldap_read.

How can I get the particular user/all users email address by using this FM and what could be the wrong with the parameters that I am passing to FM.

Regards

Murthy

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on May 07, 2014 at 11:41 PM


    Hi,

    Were you able to resolve this error. I am facing the same issue in reading Email address from LDAP. LDAP MAP is done and LDAP Server configuration is also done. Please let me know how you got this resolved.

    Thanks,

    Shobana

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.