Skip to Content
avatar image
Former Member

WebGUI standards mode with Internet Explorer

Hello

We are using WebGUI through Portal iViews. Portal uses Ajax Standards Framework and transaction iViews are shown within the Portal framework.

WebGUI is rendered in quirks mode.

In order for the transaction iViews to work with Internet Explorer, we needed to find a solution for WebGUI to render in standards mode. Otherwise a pop-up will occur that IE is in standards mode, but the iView is in quirks.

We implemented notes 1926394 and 2140417 (as well as some other prerequisite notes), which should enable WebGUI to use the parameter ~WEBGUI_NEW_DESIGN=1, so that it would be rendered in standards mode (refferring to Note 1970689)..

Now, the parameter ~WEBGUI_NEW_DESIGN has been set for the webgui service, but I still get the same error pop-up than before. So I reckon that for some reason the parameter does not work, although implementation of these notes seem to be fine.

System's kernel version is 721 - is it possible that the kernel version is causing this error or has anyone else had this problem?

I came acrosse note 2007142 which is a kind of a prerequisite for ~WEBGUI_NEW_DESIGN to work (according to note 2140417), but the manual activities described in the note are present in the system, so I don't need to modify the descibed parameters.

Any help or ideas are appreciated.

Maia-Lii

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Feb 28, 2017 at 06:35 PM

    Here is what finally solved it for us (the issue with IAC transaction iViews not rendering in the correct document mode). In addition to ensuring that the backend ICF services (in this case, /default_host/sap/bc/gui/sap/its/PV7I and PV8I) had the parameter ~WEBGUI_NEW_DESIGN set to 1 in the GUI Configuration, I had to change a parameter for the AppIntegrator in the portal.

    Via NetWeaver Administrator, go to Configuration -> Infrastructure -> Application Modules. Find the web module com.sap.portal.appintegrator, and then in the web module details find the portal service component Common_Configuration. In the portal service details, locate the property Default value for Browser Document Mode parameter. We found it was set to EmulateIE8, and that was the problem. No amount of trying to force "sap-ie=edge" in the iView properties or in the ICF configuration could override this. I changed that to edge and everything worked. It didn't even need a portal restart.

    I was able to narrow down that the AppIntegrator was the source of the problem first through an http trace, where I could see this parameter, sap-ie=EmulateIE8, being sent in the URL of the http post call to my backend system. Even when I forced sap-ie=edge in the iView parameters, the trace would show both of them, with the EmulateIE8 coming later, and therefore overriding the edge setting. If I did a "preview" test of the iView directly from Portal Content, everything worked fine, so I was pretty sure it wasn't a problem with the ICF service or with the iView. Based on the http trace, I found the AppIntegrator in Portal Content (Content Administration -> Portal Content Management -> Portal Applications -> com.sap.portal.appintegrator.sap), and within that was a function for TestIViewURLGenerator. When I put in the parameters for my IAC iView, it caused the compatibility error. Then it was just a matter of figuring out where this property was coming from, as there was nothing in the portal content properties for the AppIntegrator. It required going to the NWA to find it, as I described above.

    Hopefully this will help you!

    Cheers,
    Matt

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 24, 2017 at 09:19 PM

    Hi Maia-Lii,

    I've been struggling with the same basic issues, trying to prevent the pop-up about mismatched browser modes when accessing WebGUI-based applications via an iView in the Enterprise Portal. In our case, we've just upgraded our portal from 7.01 to 7.50 and, like you, switched to the Ajax Standards Framework, but our backend ABAP system is still running on 7.01.

    Something you wrote here finally solved most of it for me: Note 2140417, plus the manual actions from Note 2007142. These combined solved the problem for basic WebGUI reports called from an iView, and for the WebGUI running directly in a browser as well. So, thank you!

    I am still having issues with calling some ITS transactions directly, however; specifically, PV7I and PV8I (for Training and Events Management). I can't seem to make those work in standards mode.

    Otherwise, in your case, do you have a high enough patch level for your 721 kernel? That basic kernel should work, but you need at least pl 419 for it, per Note 2140417 (other Notes mentioned a lower patch level, but this one says the feature didn't work properly until this higher level).

    You mentioned that the manual activities from Note 2007142 already existed in your system, but double-check that carefully. Ours were about 2/3 of the way there. We had the WEBGUILOCALMIMES feature in SITSPMON, but it only had the X under KA, not under DA, even though we had a high enough Basis SP level. Plus, it didn't show up in table IACFL. I had to manually add it to the table for it all to work.

    Cheers,
    Matt

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 25, 2017 at 12:04 AM

    Something else to check -- are you forcing particular document modes, or perhaps "enterprise mode" centrally via Group Policy? I just figured out that in fact we are doing that here for my ABAP server, and that was forcing the IACs served up it to "downgrade" to document mode IE10 while the portal was running in Edge mode.

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 09, 2017 at 04:25 PM

    Hi guys, Please for those issues check also the SAP KBA 2395988 and 1970427. Note also that the SAP-IE can be direct in the ITS service. Regards, Fabio

    Add comment
    10|10000 characters needed characters exceeded