Skip to Content
Former Member
May 30, 2012 at 05:51 PM

Graph - Correct Lines but Values show $0


I'm using Crystal Reports XI

I have the following graph:

The lines appear to be (relationally) correct for the values, however as you can see all the values are showing $0M. If I hover over each datapoint, it shows me what would be the correct value for the Yellow line whether I hover over yellow or blue (ie, 2011 Q1 Yellow shows 105880 and 2011 Q1 Blue shows 105880).

For the curious, the values are as follows:

Yellow Blue 2011 Q1 105880.00 34130.05 2011 Q2 111282.00 45072.67 2011 Q3 110495.00 49933.12 2011 Q4 95768.67 29735.59 2012 Q1 114260.00 52252.05

I should point out the values are not direct from the database but are calculated.

I should also point out that the error only occurs on sub-reports. On my report I have one graph which is directly on the report. Then there are seven other graphs in subreports which are all then placed on the main report. The main report graph is correct, all the subreport graphs have the same issues noted above. The calculations for each subreport are part of that subreport (that is, I'm not passing any values other than linking the parameters)

I tried adjusting the "Data Values" options on the "Axes" tab of the Chart Expert, but no combination I tried has any real effect.

So, what am I doing wrong and, more importantly, how do I fix it?