Skip to Content
author's profile photo Former Member
Former Member

[BPC 7.5] Problem with transformation file

Hi,

I am trying to load data from a text file into BPC. I have set up a transformation file and all the necessary conversion files and the data basically loads. The only problem I have is that my decimals, which exist in the text file, are not imported.

A line from my text file looks like this

1104;2011.DEC;123456;100;I_NONE;765432,98

The important thing to note is the decimal separator, which is a comma instead of a point. On the SQL server for BPC we use a point.

In my transformation file I have therefore added a line in the *OPTIONS section which reads.

AMOUNTDECIMALPOINT = ,

Unfortunately this does not seem to do anything. I have tested this hypothesis by replacing all commas in the data file with points and then removed the line from the transformation file. After this the data loaded as I would expect, including the correct decimals.

Where am I going wrong as I have used the AMOUNTDECIMALPOINT = , successfully in the past.

Thanks for any help in advance,

Arnold

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    Posted on May 30, 2012 at 04:55 PM

    Hi Arnold,

    yes "AMOUNTDECIMALPOINT=," (try without spaces) should be enough and check if "ROUNDAMOUNT=" without values.

    Kind regards

    Roberto

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 07, 2012 at 10:30 AM

    Hi Arnold,

     

    What are the value that you have set into 'DELIMITER' or 'OUTPUTDELIMITER' ?

    You need to be aware that 'AMOUNTDECIMALPOINT' should not have same value with 'DELIMITER' or 'OUTPUTDELIMITER' because the decimal character should not be a character which separates dimensions.


    I am not sure if the comma ( , ) is allowed or not to be used for the option 'AmountDecimalPoint'.


    If you want to use the comma ( , ) as decimal point character, you can use this workaround:



    ===========<Transformation file =========================
    *OPTIONS
    FORMAT = DELIMITED
    HEADER = YES
    DELIMITER=
    VALIDATERECORDS=NO
    OUTPUTDELIMITER=:
    ROUNDAMOUNT = 7
    *MAPPING

    *CONVERSION



    *OPTIONS
    FORMAT = DELIMITED
    HEADER = YES
    DELIMITER= :
    VALIDATERECORDS=No
    OUTPUTDELIMITER=:
    AmountDecimalPoint = ,


    *MAPPING


    *CONVERSION


    Regards,

    Anouar

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.