Skip to Content
avatar image
Former Member

Timestamp change during Import

Hi All,

Could anyone please help me in understanding the below thing.

I know that if we have a timestamp field it changes whenever we import and value gets changed for that particular field.

But my concern  is if i am autoimporting the same file without any change( neither in XML input file neither in data manager) the timestamp is getting changed.Could anyone please tell me the reason for this.

Is this anything to do with setting of Skip Unchanged Records=True/false in MDS.ini file or any NULL handling case.How can  we avoid this? 

MDM version :-  7.1 SP07

Regards

Nitin

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • May 30, 2012 at 10:00 AM

    Hi Nitin,

    PLease update the matching action.

    What is the field you are using as timestamp,is it Update date?Please detail its usage.

    Thanks,

    Ravi

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 30, 2012 at 02:01 PM

    Hi Nitin,

    Since their is no change in the Input file and the data sitting in Data manager, what is the Import action you are selecting is it Updated all mapped fields or Update only Null values??

    Rgds,

    Prasad

    Add comment
    10|10000 characters needed characters exceeded

  • May 31, 2012 at 08:53 AM

    Hi Nitin,

    I gave it a thought and it seems likely that your import action is either Update mapped or Replace.

    In case of replace the timestamp will change for obvious reasons (deletion followed by creation of record) whereas in case of Update mapped it seems you have calculated fields in your model.

    These calculated fields are getting recalculated even with import of same data.

    Please comment.

    Thanks,

    Ravi

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 01, 2012 at 04:35 AM

    Hi,

    The import map contains of both action Create and Update all mapped fields in same map.

    And also there is no calculated field in our model.

    I also found a thread with same concern and also reply was related to Skip unchanged records in mds.ini file.

    http://scn.sap.com/thread/1887066

    Regards

    Nitin

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 05, 2012 at 08:41 AM

    Hi All,

    I tried the scenario by using the parameter " Skip Unchanged records" at repository level.

    In MDS.ini file i kept the parameter unchanged at server level and at repository level i set the parameter " Skip unchanged records=True"

    But still the timestamp was changing for the import of same file without change.

    Actually we have another field say X of Time stamp which gets changed for every import and because of this change the Modified data field say Y( timestamp) is also getting changed.

    The field selected for X is of type lookup field.

    Kindly reply to this post for solution

    Nitin

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Ravi Verma

      Hi Ravi,

      Thanks for the try and your reply.

      Actually for me even timestamp gets changed for Text field also.

      Below are the steps i performed

      1. Changed the parameter " Default Skip unchanged records =True",first at repository level - did not succeed,changed at server level , but same results.( server restarted each time after changes were done )

      2. Took the same XML file and mapped only 5 field of Text data type and tested, but still timestamp changes( Skip maintained still at server level only)

      3.Created a new file ( delimited text),created port and autoimported ,but still timestamp changed

      I do not know where am i going wrong or is it the MDM behavior

      Regards

      Nitin