Skip to Content
author's profile photo Former Member
Former Member

APS service start up issue with BI 4.0

We are running BI 4.0 Sp2, Patch 15 in our DEV environment on Windows. All of a sudden this afternoon we starting having issue with the BO services in one of the 2 clustered boxes. First Tomcat wouldn't start at all, failing at every try. After trying a server reboot, all other services are coming up except for the Adaptive Processing Server. I enabled trace on APS and after sifting through a lot of info, found this:

M [Thr 3600] ***LOG Q0I=> NiPGetHostByName: '$SMDAgentHost' not found: getaddrinfo [ninti.c 895]

M [Thr 3600] *** ERROR => Main agent failed to be initilized due to incorrect host setting! [ncsmtdatasen 22]

M [Thr 3600] *** ERROR => Main agent failed to be initilized due to incorrect host setting! [ncsmtdatasen 22]

M [Thr 3600] NCS trace timer is disabled since the interval is set to 0

M [Thr 3600] NCS data timer is disabled since the interval is set to 0

M [Thr 3600] NCS library version 2.3.8 (unicode) loaded

M [Thr 3600] NCS_ProcInit API invoked

Any idea what might be going on? the APS services just don't want to come back up! Also, we have been unable to uploaded universes/objects to the CMS since this started happening even though the CMS services and I/OFRS seem to be up and running.

Thanks!

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    Posted on Dec 03, 2013 at 08:03 AM

    hi Sarang,

    when i checked your error post it says the following

    incorrect host setting!

    can you please check the host file settings in your windows box if you are using a windows server.

    I have faced a similar issue with BO 3.2 and resolved by correcting the host file.

    please do check there and if you have any entry for BO servers or clusters try disabling all of them and try again.



    Add a comment
    10|10000 characters needed characters exceeded

    • Sarang hasn't been on this post for 6+ months..

      @David - I'm kinda surprised that you're company is running BI 4.0 SP2 Patch 5 .

      That was the minimum version that was ever shipped/generally available to the market ( back in mid 2011) that was effectively the base release, as everything before it was pre-release/ramp-up software.

      It's not clear how much RAM is available to your BIPlatform, nor if you have 'split' the APS (i.e. create a dedicated APS just for the MDAS use-case), nor is it clear how much -Xmx?G you have 'bumped up' in the command line.

      Here's how to split APS : Best Practices for SAPBO BI 4.0 Adaptive Processing Servers

      here's a BIP sizing guide SAP BusinessObjects BI4 Sizing Guide

      the problem with your version is that we have since (several times) upgraded the verious JVMs to later and more stable versions.. so it's very hard to make a meaningful assesment, because all these issues were potentially fixed at the time (almost 3 years ago)

      Thanks & regards,

      H

  • Posted on May 30, 2012 at 07:35 AM

    Hi,

    the sap host agent and ncs instrumentation would be used by the Monitoring application in CMC.

    i had this problem after patching. a number of settings had reverted: Platform Search was indexing again, Monitoring Application was enabled, Auditing was back on etc

    you should disable the 3 things above, and stop unecessary processing servers. then your platform will stabilise.

    this problem may be indicative of a shortage of memory resource.

    Regards,

    H

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.