Skip to Content
author's profile photo Former Member
Former Member

No access: 403 Please verify the settings: WebDavSlide-Repository

Hi,

We are getting the below error message while connecting from Authoring Environment to Portal KM.

When we access the same Portal KM LSO folder url outside via browser we are able to access it properly.

Error Log:

No access: 403

-> Please verify the settings: WebDavSlide-Repository: [ServerURL=https://<portal host>:<port>/irj/go/km/docs/lso/learningcontent

  1. com.sap.hcm.ls.shared.repository.access.NoAccessException: No access: 403

-> Please verify the settings: WebDavSlide-Repository: [ServerURL= https://<portal host>:<port>/irj/go/km/docs/lso/learningcontent

at com.sap.hcm.ls.shared.repository.access.wdslide.WDRepository.checkAccessability(WDRepository.java:402)

at com.sap.hcm.ls.shared.repository.access.Repository.checkOnlineState(Repository.java:120)

at com.sap.hcm.ls.las.repository.explorer.ConfigContext.checkMasterAccess(ConfigContext.java:886)

at com.sap.hcm.ls.las.repository.explorer.ConfigContext.goCMOnlineCore(ConfigContext.java:815)

at com.sap.hcm.ls.las.repository.explorer.ConfigContext.goCMOnline(ConfigContext.java:767)

Please share your views.

Thanks

Phani

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • Posted on May 24, 2012 at 04:38 AM

    Hi,

    Looks like it might be an authentication issue... are you asked to logon? Have you setup logon details in the authoring tool?

    Must be something like this.

    BRgds,

    Simon

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Thanks for your response.

      AE asked us to enter the ECC user details. We have provided the ECC user id and pwd which are same for Portal as well.

      Checked the KM LSO folder access to the user and the user has full access.

      Anything else shall we check?

      Please share your views.

      Thanks

      Phani

  • Posted on May 24, 2012 at 05:28 AM

    What do you mean when you say

    When we access the same Portal KM LSO folder url outside via browser we are able to access it properly.

    Outside via browser means??

    What kind of authorization have you set up for the WebDAV repository?

    Sandip

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      I mean through AE to ECC to KM LSO Folder connectivuty got failed for the url

      https://<portal host>:<port>/irj/go/km/docs/lso/learningcontent

      Where as when we tested this url in browser, the same user can access it properly.

      Can you please tell us where can we check the authorization set up for the WebDAV repository?

      We have checked the LSO Folder access which is reside under Content Administration--KM Content ---and user has full access to LSO Master Respository

      Thanks

      Phani

  • Posted on May 24, 2012 at 06:32 AM

    Hi,

    Have you setup the SSO (trust mechanism ) between the ECC system and the Portal ?

    Regards,

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Has this issue been resolved. We have similar issue. We implemented SAP Portal SSO using SAML2. Authoring tools will work fine when we disable SSO but when we enable SSO we get the following message:

      No access: 501

      -> Please verify the settings: WebDavSlide-Repository:

      [ServerURL=http://cgsap.capgroup.com/irj/go/km/docs/cgsap/lso]

      com.sap.hcm.ls.shared.repository.access.NoAccessException: No access:

      501

      -> Please verify the settings: WebDavSlide-Repository:

      [ServerURL=http://cgsap.capgroup.com/irj/go/km/docs/cgsap/lso]

      at

      com.sap.hcm.ls.shared.repository.access.wdslide.WDRepository.checkAccessa

      bility(WDRepository.java:402)

      at

      com.sap.hcm.ls.shared.repository.access.Repository.checkOnlineState(Repos

      itory.java:120)

      The complete error message in the attached word document "NO Access

      501".

      If your issue has been resolved can you share the solution.

      Thank you

  • author's profile photo Former Member
    Former Member
    Posted on Jan 13, 2016 at 10:57 PM

    Has this issue been resolved. We have similar issue. We implemented SAP Portal SSO using SAML2. Authoring tools will work fine when we disable SSO but when we enable SSO we get the following message:

    No access: 501

    -> Please verify the settings: WebDavSlide-Repository:

    [ServerURL=http://cgsap.capgroup.com/irj/go/km/docs/cgsap/lso]

    com.sap.hcm.ls.shared.repository.access.NoAccessException: No access:

    501

    -> Please verify the settings: WebDavSlide-Repository:

    [ServerURL=http://cgsap.capgroup.com/irj/go/km/docs/cgsap/lso]

    at

    com.sap.hcm.ls.shared.repository.access.wdslide.WDRepository.checkAccessa

    bility(WDRepository.java:402)

    at

    com.sap.hcm.ls.shared.repository.access.Repository.checkOnlineState(Repos

    itory.java:120)

    The complete error message in the attached word document "NO Access

    501".

    If your issue has been resolved can you share the solution.

    Thank you

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.