Skip to Content
avatar image
Former Member

new fields doesnt appear in sm30

Hi,

There is a custom table for modification in sm30. I have added few 2 new to this table , delete and re-generated table maintenance view via Table Maintenance Generator.

Unfortunately, these 2 new fields are still not visible the table. How can I make them visible?

Thanks

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

12 Answers

  • Best Answer
    avatar image
    Former Member
    May 18, 2012 at 09:25 AM

    Hi,

    Do you already have some data in that table for which you have generated the maintenance?

    As far as I can understand you added two fields to the table post generating the maintenance.

    try adjusting the database :

    Utilities->database object-> database utillity

    you would reach the screen that follows:

    Click on activate and adjust database.

    Are you getting any runtime error when you try to execute sm30?

    Regards,

    Aastha


    sdn.png (18.2 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 18, 2012 at 09:11 AM

    Hi,

    Try to Activate the function group used in Table Maintenance Generator again.

    You can activate function group from SE80.

    Thanks,

    Preethi Pushparaj

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 18, 2012 at 09:10 AM

    Hi,

    Do you already have some data in that table for which you have generated the maintenance?

    Regards,

    Aastha

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      HI,

      May be you did notmaintain the labels in the data element level  for all the fields, check it once. for that reason you are not able to see.

      Karthik.R

  • avatar image
    Former Member
    May 18, 2012 at 09:13 AM

    Hi,

    For the table goto

    Utlities----> Table maintenance generator---->then click on pencil button on application tool bar---->click on Expert Mode----> Click on Refresh overview screen---->Click on enter.

    Hope it serves useful to you.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 18, 2012 at 09:13 AM

    They are visible in Se11 but not in SE16 is it?

    Can you try deleting and creating TMG again? If you have access to SE14, try adjusting the databse also. That should help!

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 18, 2012 at 09:30 AM

    Only option is to delete exisiting table maintainance generator and create it again.

    This is basic and well known problem with table maintainance generator.

    Priya.

    Add comment
    10|10000 characters needed characters exceeded

  • May 18, 2012 at 09:32 AM

    HI

    try to delete the tmg and again maintain it or se14  i think so both will help (Not sure).

    Regards

    Mahesh

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      your creating the through table view or through table TMG  only.

      IF your creating throught Table view you shd delete the View and then you shd create new and select all fields in View then only it will show in TMG output.

      Because i also faced same issue last 10 days back.

      Regards,

      Raghavendra.

  • avatar image
    Former Member
    May 18, 2012 at 09:36 AM

    Hi,

    Go activate the Table in SE14 and Activate the Function Group also .

    Come back to main Screen and run the T-code it will work out.

    Regards,

    Raghavendra

    Add comment
    10|10000 characters needed characters exceeded

  • May 18, 2012 at 09:37 AM

    Delete your current table maintenance and recreate the same.. make sure that there are no custom developments inside the existing TM Function Module

    Add comment
    10|10000 characters needed characters exceeded

  • May 18, 2012 at 10:31 AM

    PLease delete the table maintance genrator and and genarate againand also se14 adjust data base

    Add comment
    10|10000 characters needed characters exceeded