Skip to Content
author's profile photo Former Member
Former Member

Need help in LSMW

Hi,

While I am doing LSMW for FB01 transaction, in step "Display Converted Data" it is giving special character for empyt field is '/'. Can any one tell me, what should be done to keep empty field as blank.

Regards,

Sandesh.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jun 14, 2005 at 07:19 AM

    Hi Sanjay,

    Your LSMW is using a batch input for transaction FB01.

    In batch input it is sometimes necessary to leave out some field on the screen your processing.

    In your input file sometimes fields can be filled and sometimes not.

    The question is what to do with those fields:

    1. Should the field on the screen be made empty

    2. Should the default value on the screen be kept.

    For purpose 2 you can a special character in your input file (/).

    This will indicate to the LSMW program that generates the batch input session that this field should not be used/filled.

    In this way you can preserve default values without overwiting them with blank values.

    Hope this was helpfull.

    Regards,

    Arjan Aalbers

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 13, 2005 at 07:01 AM

    Hi,

    Just create a rule where you set the particular field to space. Something like this:

    move space to field.

    Good luck,

    Marcel

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jun 10, 2005 at 12:39 PM

    hi,

    In proces step -> Specify files try not marking option "Field order matches source structure definition".

    Best regards

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Since I am doing LSMW for FB01 trabsaction, wherein I have to transfer "Data for Multiple Source Structure (Header and Line Item document)". While I try to remove the tick from "Field order matches source structure definition", it is giving me the error "Ensure field sequence is correct for data for mutiple source structures". Can you suggest me what option to select in that Specify File step for transferring data to Multiple Source Structure.

      Any help from your side will be kindly appreciated.

      Regards,

      Sanjay.

  • Posted on Jun 13, 2005 at 06:01 AM

    Hi,

    since i´m not an expert in lsmw i´ve just found this in a yahoo forum (maybe this can help):

    "If you are using transaction FB01 then use the standard program RFBIBL00 from within the LSMW, don't record your own".

    "Use standard object 100 Method 00".

    Best regards.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.