Skip to Content
author's profile photo Former Member
Former Member

error while deploying a webdynpro application

I made a simple welcome webdynpro application in netweaver developer studio .When i go to deploy it by opening the node "applications" and choosing "deploye new archive and run " option from the context menu of my application , it gives an error in the 'deploy output view" of the netweaver developer studio which says " Deployment aborted " . If you double click on the error a window opens up and it gives a description of the error which says " Cannot determine the SDM host(is empty). please configure engine/sdm correctly ".

Also when i click the tab J2EE engine in the netweaver developer studio it shows remote engine sever and branching into N/A and crossed in red. My J2EE engine is running as I am able to see the administration page of the EP.

The netweaver developer studio that I am using is the one that came with the sneak preview of EP 6.0 SP9 and the EP that I am using is 6.0 , the original licensed software.

Can someone please let me know what is happening here ?

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jun 09, 2005 at 01:15 PM

    Hi

    please check your Port Number in sapJ2ee Engine

    and see in the J2EE Engine tab that ur server is running stage

    I think that shuld be the Problem

    u have to configure the same in window->Preferences->J2EE Engine.

    u have to give ur Host and Port Number.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 09, 2005 at 01:21 PM

    Hi Deepak,

    Did you enter the "Message Server Host" and "Message Server Port"?

    If not enter and try.

    You can enter "Message Server Host" and "Message Server Port" by navigating to the following menu in the NWDS "Window --> preferences --> SAP J2EE Engine".

    If you require any further help do let me know.

    Regards,

    Santhosh.C

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 10, 2005 at 06:11 AM

    If the engine is installed on different machine please give the hostname/IP of that machine in the MessageServer Host inputfield .

    Using the second radio button you can select the local engine instances.

    Regards, Anilkumar

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Pran ,

      I checked for the service which you suggesetd but i could not find any entry there by the name "sapms" . Should I create one with the same port which appears in window for J2EE engine configuration ?

      I also checked for the /usr/sap folder. It is shared and sharing names are sapmnt and sapprt . No name as saploc appears. Should i add that ? Are these names case sensitive ?

      Regards

      Deepak Singh

  • author's profile photo Former Member
    Former Member
    Posted on Jun 17, 2005 at 08:12 AM

    Verify ythe following

    C:\WINNT\system32\drivers\etc\Hosts.File

    Enter machine IP details like "127.0.0.1 localhost" in this file and try.

    Regards, Anilkumar

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      hi Deepak,

      I have also installed NDS on my server.So when I go to preferance->SAP J2EE Engine and click on SAP J2EE Enginee installed in Localhost button and then browse I get system name and on clicking that all the three field itself get filled.

      I think you should re-install Netweaver Developer Studio and then try again.

      Regards,

      Rajeev

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.