Skip to Content
avatar image
Former Member

TSV_TNEW_PAGE_ALLOC_FAILED but HEAP MEM not use

HI!

when users running t-code VL06O for more than a year in st22 i have dump TSV_TNEW_PAGE_ALLOC_FAILED .

This dump occurred only when using VL06O .

In st03 for than month i have no used heap/private memory .

In st02 -> detail analysis -> sap memory -> history  same situation (Heap memory sizes USED = 0)

sappfpar checking with no errors and warnings.

my profile param's:

em/initial_size_MB = 24000

abap/heap_area_dia = 2000683008

abap/heap_area_nondia = 2000683008

abap/heap_area_total = 2000683008

ztta/max_memreq_MB = 2047

ztta/roll_area = 13000320

ztta/roll_extension = 4800683008

ztta/roll_first = 1024

rdisp/PG_SHM = 8192

rdisp/PG_MAXFS = 35768

rdisp/ROLL_SHM  = 66384

rdisp/ROLL_MAXFS = 82768

Please share your experiences 😊

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    May 14, 2012 at 02:29 PM

    can you please extend the ztta/roll_extension to 8 GB and then try .

    Also paste the error details from the ST22 runtime error. Please check the max extended memory and heap memory used.

    Please check how much of extended memory was used by the user . ST02 -->click on extended memory -->click on mode list.

    Please check the memory usage when the program is getting executed.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      thanks all for you help!!

      i understand reason of my problem

      The problem was in  Vl06O parameters

      when the user inserts a huge list of numbers of materials, report eats 9400mb and fails with this dump.


      if do not specify this list of numbers of materials and simply select all of the materials, report uses 100MB

  • avatar image
    Former Member
    May 21, 2012 at 01:38 PM

    Hi,

    You can find the exact time and the work process number in the shortdump.

    Please check the WP log and search for the time.

    You can find there the parameter which you should increase.

    Laszlo

    Add comment
    10|10000 characters needed characters exceeded