Skip to Content
avatar image
Former Member

MII can't find PCo's WSDL

We need MII to use PCo to connect to our OPC server. But when I try to create a new PCoConnector and enter the PCo URL, I get a strange error.

I type this PCo URL:
http://c111spzbltfth:50050/PCoManagement
And I get this error message:
"Error occurred while fetching the PCo agent list; WSDL could not be found for URL http://c111spzbltfth:50050/PCoManagement?wsdl"

The strange thing about this error is that if I simply paste the same URL (http://c111spzbltfth:50050/PCoManagement?wsdl) into a browser, I see a perfectly good WSDL.

PCo is connecting to our OPC server just fine, but we can't create an MII connector to PCo because of this error.

We have:
MII 12.2.3 Build(179) on a Linux server
which connects to
PCo 2.2 (2.200.894.206 Patch level 28528) on a Windows 2008 server
which connects to
FactoryTalk Gateway, an OPC DA server (OPC-DA 2.05a) running on the same Windows 2008 server

I would appreciate any advice. Thanks in advance.

Message was edited by: Gregory Boettcher (screenshots added)

shot1.PNG (21.3 kB)
shot2.PNG (35.9 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    May 16, 2012 at 01:16 PM

    Our team contacted SAP for help and got the following reply. It seems this issue has been identified as a bug and will be fixed in an upcoming SP.

    The reason for the issue was identified and the fix will be included in
    the next SP - SP04. The scheduled date for the release of SP04 is July
    10th [2012].

    Add comment
    10|10000 characters needed characters exceeded