Skip to Content

GETWA_NOT_ASSIGNED in formula with amount

Hi, I have a formula with an amount. When the formula is executed, a short dump GETWA_NOT_ASSIGNED occurs in method CL_FDT_FORMULA_ELEM_FUNCTIONAL->RESULT_CONVERT( ), line 21:

ASSIGN COMPONENT 1 OF STRUCTURE <ls_result> TO <lv_value>.
<ls_amount>-number = <lv_value>.

The structure <ls_result> is not a 2-component structure with number/currency, as the code expects, but of the elementary type NETWR instead.

How to proceed?

- Rüdiger





Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on May 07, 2012 at 05:32 PM

    What release and SP are you on?

    We have improved the formula parser for better message output and full support of cancelling out units and currencies.

    In doubt open a ticket. A dump should of course not occur.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.