Skip to Content
0
Former Member
May 02, 2012 at 01:02 PM

Smartform field cannot be changed problem

1012 Views

Dear All;

I'm having an issue about a smartform that im using for purchasing order.

I'm trying to make some changes with a piece of code to some certain texts in the smartform and it works for some of the text while it doesnt for some others.

The one which works is "WA_EKPO-TXZ01" defined in Global Definition/Global Data, and other which doesnt work is "WA_LFA1-NAME1" defined in Form Interface/Import. When I try my code on "WA_LFA1-NAME1", i get this error : "The field "WA_LFA1-NAME1" cannot be changed. ."

My piece of code for the texts is like this (below is for WA_EKPO-TXZ01) :


perform f_used_char USING WA_EKPO-TXZ01
CHANGING WA_EKPO-TXZ01.

I have tried using a local variable instead of working with "WA_LFA1-NAME1" like this:

lv_name1 = wa_lfa1-name1.

perform f_used_char USING lv_name1

CHANGING lv_name1.

And with that of course I use my text field like this:

To : &LVNAME1&

However, my LV_NAME1 never gets to the TEXT field. I have checked the SE63 for translation and saw that my TEXT field still gets its value from "WA_LFA1-NAME1" not from LV_NAME1. I dont want to change it from SE63 manually because god knows how many languages that smartform uses. So is there anyway that smartform can get this LV_NAME1 for that text in every languages dynamically?

I hope I was clear, please respond back if you have further questions. (I tried to be as much clear as I can)

Thank you

Talha