Skip to Content
0
Former Member
May 02, 2012 at 10:29 AM

Table within the pop up disables row selection

13 Views

Hi All,

I am facing a very peculiar problem. I have a main view, with a button which displays a pop up window. The view within the pop up window has a table and few buttons. All works fine when the main view is displayed.

I have embedded this main view in another view which is called through the UWL in portal. When the pop up is invoked by clicking the same button in main view, the table in pop up window is disabled, the row selection doesn't work. Rest of the UI elements in the pop up window work as they should. They get disbaled, enabled, visible, invisible based on logic and their context binding.

There is no binding of the table for enabling or disbaling the table, but still it remains disbaled, with the first row selected by default. The lead selection just doesn't change.

I wrote code in the onselect event, which gets triggered when a row is clicked,and tried setting the lead selection, but still no success.

Any help in this regard will be great.

Runal