Skip to Content
0
Former Member
Apr 27, 2012 at 08:17 PM

Need to make field RQEVA-SGTXT01 required when using QA11 and QA12 (553)

72 Views

Hello everyone,

Question 1: How / where do we enter text into the RQEVA-SGTXT01 field, and how do we make it required (can not save without entry)?

Question 2: How do we get it the RQEVA-SGTXT01 to also be displayed in MSEG-SGTXT?

Our Quality department is using QE51N for results recording, once the results have been recorded, they go into QA11 to make a usage decision. If the usage decision is "Rejected" they then go into the "Inspection Lot Stock" tab and select the "VMENGE To Scrap" function and apply it to all HUs (this scraps out the HUs via a 553 movement type). It is at this point, they would like to enter a reason code and a reason text.

We are on ECC 6.0 eph4.

I have done the following...

I went into OMJJ (for movement type 553) because the HUs are on "Q" hold at this point. I selected "+" in the Control Reason field to make it required. Under the "Field Selection (Enjoy)" I have made GRUND and SGTXT required. I have also entered a "Reason for Movement" code (0001-Failed Incoming Inspc.).

I also went to OQFA in module pool SAPMQEVA and flagged the fields GRUND and RQEVA-SGTXT01 as required.

However, when the Quality people select the "to scrap" option and press the "save" button. The program just completes, it does not require a text entry anywhere and I do not see where it should be entered. There are usually some special comments that need to be recorded, so they want to use this field.

If I go to MB51, I do see the reason code. But we need to see the text behind it as well, which should show up in MB51 under MSEG-SGTXT.

Thanks in advance for everyone's help, it will be greatly appreciated.

Rhonda