Skip to Content

IDOC error Partner profile + Message variant

Hi all,

I am sending some IDOCs to a SAP system. I am getting this error:

EDI: Partner profile inbound not available

I have check SAP System and there is defined the partner profile, but this partner profile is using a message variant. If I don`t set the message variant I dont get this problem, but if I do it get this error.

How can I configure IDOC receiver adapter to set the message variant?

Many thanks.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Posted on Apr 26, 2012 at 10:45 AM

    Hi,

    You can set the message variant during the message mapping, and additionally you have to set the "Apply Control Record Values from Payload" indicator in the receiver CC for the change to take effect. You can read more about setting IDoc control record fields values in this blog by @Michal Krawczyk

    : XI: IDOC Adapter - EDI_DC40 - demystified. Don't forget to "like" or rate the blog if you find it useful 😊.

    Regards,

    Greg

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.