Skip to Content
author's profile photo Former Member
Former Member

UOM not displayed for 9ASVTTY and 9ASAFETY key figures

Hi All,

I have 2 key figures 9ASVTTY and 9ASAFETY defined in the planning area. I have 2 different planning books with these 2 key figures in it.

When I load data, the UOM "Days" is not displayed for the 9ASVTTY key figure and the base UOM is not displayed for the 9ASAFETY key figure.

I check the planning area settings and found that a value of 10 is shown against the "UOM" field. 10 is an internal unit of measurement format for the commercial unit of measure "D".

It seems that the system is not picking up the commercial UOM for this particular key figure.

However in another planning book, which contains only these 2 key figures, the UOM is displayed correctly when I load the data.

Both the planning books are created on the same planning area.

Another question, is key figure function mandatory to be defined in the data view settings, in order for the UOM to be displayed in interactive planning?

Thanks,

Kedar

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Apr 26, 2012 at 07:04 AM

    Hi Kedar,

    You can check the value of field "UOM PLAN" in table /SAPAPO/TSPAPLOB for below combination:
    PAREAID 9ASNP05 PAREAID 9ASNP05
    PLOBID 9AMALO PLOBID 9ASNPBAS
    KEYFIGURE 9ASVTTY KEYFIGURE 9ASVTTY
    UOM PLAN 10 UOM PLAN 10

    You need to verify whether for your planning area, the value is the same as above for the field "UOM PLAN". If not, pls maintain the value as "10" for your planning area for the above combination and check
    the issue again.

    Claire

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Kedar,

      I guess your faulty planning book would have been adopted from the std 9ASNP_SSP in which the UOM was not set for the specified key figures.

      Use t.code /SAPAPO/SDP8B, select your planning book and hit change to go into edit mode. Select 'Key Fig. Attributes' tab. Then, select these key figures one after another.

      9ASAFETY - Set flag for UOM from Product Master

      9ASVTTY - Select "D" for Unit of measure.

      Or you can refer to the settings maintained in your other planning book and update these key figure attributes appropriately.

      Thanks,

      Rajesh

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.