Skip to Content
author's profile photo Former Member
Former Member

Process Messages in "To be sent" status

Hi experts,

We send process messages to SAP using Wonderware software. Some of the process messages are stuck in "To Be Sent" status in CO54. Even if the background job to process them is running, it seems it does not post the said messages again unless we do it manually. Anyone knows what is the cause for the messages to not get posted again by the background job? The process order linked to the messages is not open so we expect the job to repost the message without error.

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Apr 25, 2012 at 06:45 PM

    Hi Paul,

    Let me know how you schedule your SAP background job to send process message. There are 2 jobs. Program RCOCB004 is to set at plant level and RCOCB002 is set at client level. Also check if you used a time based or an event based job to send process messages and parameter periodic is set in batch job. Issue might be previous job getting cancelled due to previous message not sent error. Check SM37 list for any cancelled status.

    regards

    Rijil

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Apr 26, 2012 at 12:53 AM

    dear,

    i would check out the relevant settings in O13C

    regards,

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Apr 26, 2012 at 08:53 AM

    Hi Paul,

    Have you checked whether the job that is scheduled have the proper messages mentioned " Message categories" in the variant used. Are you using the standard program "RCOCB004" or have you used some other customised, accordingly check the messages that are maintained and variant created for scheduled job.

    Regards,

    Amol Kale

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 27, 2012 at 06:09 PM

    Hi all, thank you for providing meaningful answers. We already detected the root cause. The job we're using, RCOCB004, was missing some parameters in the batch job. Thanks!

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.