Skip to Content
author's profile photo Former Member
Former Member

Java Exception When Opening Integration Builder

hi all,

Recently had to re-install SAP XI. Now everything is up and running, but need help with one issue.

When the exchange is launched, SLD and the RWB work fine and able to log in successfully. But whenever try logging into the IR or ID - it throws an "java.lang.NullPointerException".

Any suggestions on how to resolve the issue?

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jun 06, 2005 at 05:29 AM

    Hi,

    First,check out ur using which version of java web start?IS it 1.4.2 or above?if OK,then check, r u able to download all jar files in to u r local machine.....

    May be the problem occurs here.Unable to download jar files.........

    check u r proxy settings.............in web start as well as in Internet explorer.......

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 06, 2005 at 05:41 AM

    Did you try to clear the folder in the Java WebStart --> File --> Preferences --> Advanced --> Clear Folder

    Manually you can delete the folders in the directory

    C:\Documents and Settings\<userid>\Application Data\Sun\Java\Deployment\javaws\cache\http\D<xi host>

    and

    C:\Documents and Settings\<userid>\Application Data\Sun\Java\Deployment\javaws\cache\muffins\http\D<xi host>

    Regards

    SKM

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jun 06, 2005 at 05:43 AM

    Hi,

    try this weblog:

    https://www.sdn.sap.com/sdn/weblogs.sdn?blog=/pub/wlg/1688 [original link is broken] [original link is broken] [original link is broken] [original link is broken] [original link is broken] [original link is broken] [original link is broken] [original link is broken] [original link is broken]

    Regards,

    michal

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 06, 2005 at 06:24 AM

    Sridhar / SKM / Michal.

    Thanks for the feedback. Combination of your replies seems to have solved the issue. After checking the version and jar files - had to clear the cache and carry out other checks described in the weblog reference provided.

    Regards,

    sapknowledge

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Michal Krawczyk

      Hello together,

      we have a problem downloading Integration Directory webstart appliction. It´s a customers system. Inside the customers network everything works fine.

      From outside I can launch the XI-Tools site. SLD and Runtime Workbench works. While downloading the required jar-Files theres an error: Download-Error - Invalid JAR-File at http://server:J2EE-Port/rep/repository/aii_ibrep_client.jar java.util.zip.ZipException: error in opening zip file

      Is there an additional Port (apart from the J2EE-Port) have to open for downloading the jar-files and connecting the server?

      THX,

      Andreas

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.