Skip to Content
avatar image
Former Member

Transport protocol version for File adapter

Hello Experts,

I am trying to create Integration Directory objects using Integration Directory API. All the other objects are getting created successfully such as Receiver Determination, Communication component etc. however I am facing problems while creating communication channels.

While creating a communication channel, it is giving error saying specify Transport protocol version. I checked the meta-data of the adapter and found that no value is maintained for the same. Hence I passed blank value but the method CREATE is not accepting the same and repeatedly giving the same error. I tried with several values such as 1.0 or the same as of Message protocol but everytime it said 'No protocol version has been maintained'.

I tried reading the configuration of existing communication channels by using READ method and passing the same to the CREATE method but its not working either. Anyone knows the trick how to overcome this error, please let me know.

Thanks in advance.

Regards

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Apr 19, 2012 at 03:08 PM

    I have gone through William LI document http://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/c0487ced-f537-2d10-249d-f6c7323c272e?QuickLink=index&overridelayout=true&47467978777328

    Looks like Transport protocol version for file adapter is nothing. I see no value in this document work sheet. I see that you also tried sending empty space and no luck. Just give a shot 0 or 0.0 and see whether that helps.

    You might also want to glance this link

    http://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/a0336199-d3c7-2c10-c983-f8a945a4588c?QuickLink=index&overridelayout=true&46076409386760

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 04, 2015 at 01:17 AM

    Did you get any resolution?

    Thru SOAP UI it's working, but if it's called thru GUI, this issue is coming and asking for 'Transport Protocol Version' for me too.

    Did you apply any OSS note?

    Please suggest.

    Thanks,

    Mukul

    Add comment
    10|10000 characters needed characters exceeded