Skip to Content
author's profile photo Former Member
Former Member

CDPOS table not getting populated in VA01/VA02 transaction

Hi All,

I am using transaction VA02. I have a order which I am changing.
I am clicking on the item and going to the partners tab. The partners are copied from the (sold to /ship to). Now when I am changing the partner for the first time and saving it. It is saving the partner but the change log is showing me a yellow indicator instead of green indicator and also it is not showing the old and new values in the log.

I tried changing the table XVBPA/YVBPA with UPDKZ as U in userexit_save_document_prepare but it is still not working..

Regards,

Nikhil Moghe

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Posted on Apr 19, 2012 at 05:12 PM

    Hi Nikhil,

    I would suggest you go for -

    Enhancement - V45A0002
    Exit - EXIT_SAPMV45A_002

    In this I have added same logic u are seeking for ......... it worked for .....

    Try ... give a shot man !!!

    Cheers

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Ravindra,

      I think you did not got my query. The partners are getting properly copied from sold to or ship to.The problem arises when I change the partners in the partner tab at item level. This is related to VBPA table and VBPA table is not available in the exit mentioned.

      Regards,

      Nikhil

  • author's profile photo Former Member
    Former Member
    Posted on Apr 25, 2012 at 04:37 PM

    As my late granddad used to say, this is "clear as mud". You need to make a clear statement about what you are trying to do and what the problem is. From your posts, one has no clue as to how to suggest correction!

    Are you trying to edit the partners on a sales order and not able to?

    Are you trying to enter a new sold-to and copy/assign the partners based on that new sold-to entry, and that doesn't work?

    Or, are the VBPA partners updating correctly, but you're missing the change managment that displays when, who, how and old/new values?

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.