Skip to Content
0
Former Member
Apr 18, 2012 at 06:20 PM

Enhancement - Can't activate post-exit method

493 Views

Hello,

I'm facing an issue with my enhancement point: I can't activate it although I didn't write a single line of code in it! It is just a post-exit method for method CONVERT_IF_TO_UI of class CL_HRTMC_AC_DEV_PLAN.

I first faced another issue, so maybe my activation issue is related to this.

Let me describe the entire process, including the initial issue and how I solved it, and I hope somebody will tell me what I'm doing wrong.

  1. Opened SE80 for class CL_HRTMC_AC_DEV_PLAN
  2. Chose menu Class > Enhance
  3. A new window appears, with an "Enhancement Implementation" field where I typed "Z_MY_IMPLEMENTATION" and a description field where I typed some description
  4. Clicked on the "Validate" icon
  5. Prompted for a Transport Package. I chose Local Object because I'm doing some tests in Sandbox that we don't want to transport.
  6. Placed the cursor on the CONVERT_IF_TO_UI method and chose Edit > Enhancement Operations > Insert Post-Method.
  7. Got an error message saying "The class has not yet been converted to the new class-local types". To solve this, the "trick" is to do Utilities > Convert class-local types. When prompted for Access Key, click on "Display" as many times as required. Success message "Class CL_HRTMC_AC_DEV_PLAN successfully converted". Maybe my issue comes from this "trick".
  8. Can now do Edit > Enhancement Operations > Insert Post-Method
  9. Window with question "Access to Private/Protected Components of ClassCL_HRTMC_AC_DEV_PLAN?". Clicked on "Yes".
  10. Clicked on the PostExit icon that just appeared.
  11. Prompted for saving, clicked on "Yes".
  12. Tried to activate -> Error message saying that I have problems. Chose "Display Errors"
  13. Error is "Enhancement Implementation Z_MY_IMPLEMENTATION. Type "LCL_Z_MY_IMPLEMENTATION" is unknown" (Row 30). When I click on it, it brings me to the Enhancement Include tab of the Implementation Overview. Row 30 contains code "CREATE OBJECT LCL_Z_MY_IMPLEMENTATION=>OBJ"

As you can see, I didn't write a single line of code and I get an error. Needless to say, if I write some code, I still get the error. 😉

Thanks in advance for your help!