Skip to Content
author's profile photo Former Member
Former Member

Internet url without a path

Hi,

i(together with our basis guy) have tried several things but without any success. maybe someone has an idea for me.

<b>What i want:</b>

i want to publish an BSP-Service to the internet with help of a "speaking" url. Instead of:

https://<host>:<port>/sap/bc/bsp/sap/....

i want to use

https://myweb.company.de

<b>What did i do until now:</b>

First of all my service is stored in the following path:

/default_host/sap/bc/bsp/sap/..

<b>Step 1 </b>

In one first step i made an internal alias(alias1) which referes to the service in the above mentioned path.

When we tried from the internet the

https://myweb.company.de/alias1 this works fine.

Looks good, but is not to 100% what we want.

<b>Step 2 </b>

The next step to our goal is, that i tried working with an virtual_host at the WAS. When i read the documentation for virtual host, than i read the following:

...If the URL then specifies the virtual host without any additional path information, the target service that is defined will be called...

Therefore i defined a virtual_host (RZ10->is/HTTP/virt_host_1... and also in the SICF i made an entry with reference to my service.)

<i>I switched the name from the default_host to a different name and gave the virtual host the original name of the default_host (I did this because of the SSL-certificats which were created for the "original" host-name, and therefore to avoid creating new certificates and so on)</i>

In my opinion, the request to https://virt_host_1/ should start directly the service located in the subdirectory which is linked to my virtual host.

The name of the virtual host is a FQDN (myweb.company.de) and the security certificate for SSL is dedicated to the same target address.

When i call the url https://myweb.company.de from the internet now, i can see in the http-log file of the WAS-Server the following lines:

[03/Jun/2005:12:25:47 +0200] "GET / HTTP/1.1" 302 - 

After a while (the progress indicator in the browser is still running) i see the following in the http-log:

[03/Jun/2005:12:27:00 +0200] 
"GET /StartPage/StartPage/StartPage/StartPage/menu.html HTTP/1.1" 404 143
[03/Jun/2005:12:27:00 +0200] 
"GET /StartPage/StartPage/StartPage/StartPage/menu.html HTTP/1.1" 404 143
[03/Jun/2005:12:27:01 +0200] 
"GET /StartPage/StartPage/StartPage/StartPage/menu.html HTTP/1.1" 404 143
[03/Jun/2005:12:27:01 +0200]
 "GET /StartPage/StartPage/StartPage/StartPage/menu.html HTTP/1.1" 404 143
[03/Jun/2005:12:27:02 +0200] 
"GET /StartPage/StartPage/StartPage/StartPage/menu.html HTTP/1.1" 404 143

This is only a smal part of the HTTP-Log. The log is full with entries.

Unfortunately the browser don't show the desired page.

The server seems to ignore the link coupled to the virtual host and starts directly from the default root page, which causes these problems.

And i have no more idea how to publish a bsp page to the internet without having a path in the url.

Thank you for any hint on this

Thorsten

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Jun 11, 2005 at 10:23 PM

    Thorsten,

    <i>And i have no more idea how to publish a bsp page to the internet without having a path in the url.</i>

    The short answer is that it will not work. The BSP attempts to mangle the URL, which requires at least one extra segment.

    However, other people has asked about this before. What we did was build in a simple hack a long time ago. It will only work if you are using a controller with views. Then set your root node to point directly onto you BSP application. Once the BSP runtime detects such a root situation for a controller, it will stop the mangling.

    Important: there are many things tied to the mangling which might fail in this situation. It is not documented, and you should only do it if you know where the journey is going.

    One last aspect: the root / URL is necessarily passed to the ABAP stack. There is a profile parameter that controls this. See transaction RZ11, look for root parameter.

    b.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.