Skip to Content
avatar image
Former Member

Online DB2 backup including logs also includes "old" logs

Hi,

I'm trying to understand the way the first log file will be selected when an online backup (including logs) is created.

My example:

The online backup started at 18.04.2012 01:00 and included the logs S0010002.log - S0010007.log. It finished at 18.04.2012 05:05.

Why is the backup considering the logs S0010002 - S0010004, as they where already inactive at the point the backup started?

******************************************************

S0010010.LOG 18.04.2012 12:42:22

S0010009.LOG 18.04.2012 10:36:59

S0010008.LOG 18.04.2012 08:31:59

S0010007.LOG 18.04.2012 05:05:14

S0010006.LOG 18.04.2012 04:28:17

S0010005.LOG 18.04.2012 02:48:49

S0010004.LOG 18.04.2012 00:17:03

S0010003.LOG 17.04.2012 22:09:41

S0010002.LOG 17.04.2012 20:01:58

S0010001.LOG 17.04.2012 17:57:00

******************************************************

From my undertsanding the logs S0010005 - S0010007 should have been sufficient for a consistent backup.

Thanks,

Stefan

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Apr 18, 2012 at 12:07 PM

    Stefan,

    Are you sure, that there is no open transaction in the S0010002.LOG file?

    Best regards,

    Joachim

    Add comment
    10|10000 characters needed characters exceeded

    • I believe your SOFTMAX parameter value is 300 , so it will have 3 previous¬† transaction logs which still hold uncommitted change vectors . Hence the reason it has included the previous 3 logs in the backup.

      Regards

      Ratnajit

  • May 18, 2012 at 09:30 AM

    Hi All

    I can confirm the same issue on our DPF BI system. It is requiring also logs moved earlier into log_archive directory. This is a problem cause partitions 1-6 are updated during data load period and logs are generated only then. So if i'll tranfer those logs out of log_archive directory backup will fail.

    Regards

    Marcin

    Add comment
    10|10000 characters needed characters exceeded