Skip to Content
author's profile photo Former Member
Former Member

Java Services disabled and applications failed to start

Hi All,

Our Netweaver 7.3 pi abap+java system is running fine except few of the services got disabled.

These services were running last monday but today I saw 5 applications failed to start and it is because of 9 disabled services.

I am giving screenshot of these services and application. Please let me know how can i enable again the services

Disabled services:

Failed Applications:

Regards,

Sudip

6.jpg (203.5 kB)
4.jpg (221.9 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Apr 19, 2012 at 03:48 AM

    Hi,

    I would suggest to have a look at the logs/traces which are written when the services start up. Or else you could manually try to startup the services and check the log files for errors. In some cases, the service would fail to start as some other dependent services are stopped. You would have to check why the dependent services are failing to start. Please check the Logs sections in NW Administrator or on the OS level ..\usr\sap\JXX\j2ee\cluster\server0\logs, check application log and default trace files.

    Regards,

    Srikishan

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Apr 26, 2012 at 04:45 PM

    Dear Sudip,


    Hope you are doing good.

    Please try to restart the applications this way:

    1. start the telnet admin tool

    telnet <hostname> 5<instnum>08

    2. logon using the J2EE Admnistrator user

    3. lsc (to list the available servernodes)

    4. jump <servernode> (usually jump 0)

    5. add deploy

    6. start_app -all

    Wait for sometime and check if the services are up and running now.

    If you wish to change startup mode:

    Open Offline Configuration Editor: /usr/sap/<SID>/<Instance>/j2ee/configtool/offlinecfgeditor[.bat .sh]

    (this assumes a running database). Open the node Configurations -> deploy -> <hierarchicalApplicationName> change "StartUp" from 2 (lazy) to 3 (always) for all the application
    you deem fit.

    Please refer to following SAP Documentation link for more help. Although it is for 700 servers, it will help you understand the logic.

    http://help.sap.com/saphelp_nw2004s/helpdata/en/94/0a5b422f786255e10000000a155106/frameset.htm

    Thank you and have a nice day :).

    _____________
    Kind Regards,
    Hemanth
    SAP AGS

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.