Skip to Content
author's profile photo Former Member
Former Member

How do i reset a DTP delta request for an open hub connection through .net connector?

I can't seem to find a solution to reset my delta load. I have a cube that the customer wants exported to sqlserver. I've created an extract process in SSIS using the .net connector 1.0. I created an open hub destination and the corresponding DTP in full mode. This worked fine. I then changed the DTP to delta mode and it pulled all the data again, thus setting the delta "init".

I found a few articles and blogs that says to just delete out the entries in the DTP such as this one:

http://scn.sap.com/thread/1971044

I deleted the DTP requests from the monitor. It clearly shows my delta request in the deleted section. However, when i ran the delta again, it just pulled the new data and did not pick up all the old data as well. What am I missing? Does pulling data through the .net connector cause the DTP to behave differently? What is my alternative? Do I have to delete the DTP entirely and create a new one?

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    Posted on Apr 12, 2012 at 05:40 PM

    Hi,

    Once delta requested without setting the status to red, you cannot get that load

    Pull the data from cube again using FULL. Then INIT and set Delta for the same

    Regards

    Chandu

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      I resolved my issue. I stated earlier that the "Only get delta once" checkbox was set. I deleted all load requests from my DTP and still no data. I created a new DTP and it wouldn't let me because the old DTP was still active and set with a delta. The error message was something like "you cannot have two DTPs with overlapping requests".

      I deleted the old DTP and created the new DTP with the above checkbox not set. I ran a load through the new DTP and it pulled all the data over. I ran another load and no data was pulled over due to the delta request. I then deleted out all the requests and ran it again. It pulled all the data once again.

  • author's profile photo Former Member
    Former Member
    Posted on Dec 09, 2014 at 10:18 AM

    Hi Micah, I have the same problem as you. But I am not able to delete the old DTP, it wil not allow me to do that. Did you have any issue with that and how did you solve it? Thanks, Reynir

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.