Skip to Content
0

S4 HANA Customer creation, Sales and company code data is not saving.

Dec 28, 2016 at 05:06 AM

2.2k

avatar image
Former Member

Dear all,

We have a problem in creating the customer in S4 HANA 1511 Edition in the direction customer to Business partner. After the migration we have run the check report CVI_FS_CHECK_CUSTOMIZING, shows no customising errors. The assigned number range for the customer account group is consuming while creating customer using BP role company code data( FSCU00) and sales area data (FLCU01), but after saving the data is not updating in the respective tables KNB1(Customer master company code) and sales data (KNVV) however the business partner is creating and data is updating in the table BUT000(Business partner general data). Please help to resolve this.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Veselina Peykova
Dec 28, 2016 at 08:24 AM
0

Apologies for the dumb question, but are you sure that you have maintained sales area and company code- specific data for this business partner?
BP role creation FLCU01 does not necessarily mean that you have maintained the sales area specific data.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Dec 28, 2016 at 11:18 AM
0

Dear Veselina Peykova,

I won't ask for a solution if its working with all necessary sales area data fields filled correctly. :)

Regards

For your reference, i am attaching the screen shot of the config. We are following Customer to BP approach for master data creation

Customer --> BP

  • YB03 is our assigned account group for customer creation
  • Customer no range and BP No range maintained internally

Regards


bp.png (17.9 kB)
Share
10 |10000 characters needed characters left characters exceeded
Veselina Peykova
Dec 28, 2016 at 12:02 PM
0

Can you try to create the SD data manually in BP for one entry and check if you can save?

I am asking this, because recently I faced an issue with screen generation, which resulted in ABAP errors.

Show 3 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi There!

I am currently facing an issue when creating a Customer. I am getting an ABAP dump error. Could you please let me know what was the error you faced and how you resolved it.

Thanks in advance.

0

I cannot remember the exact error - it was six months ago...

In my case we ran BUSP to regenerate screens, but you are not supposed just to try out any possible solution for ABAP errors in business partner creation - you need to analyze the dump and based on this to perform corrective actions :)

0
Former Member
Veselina Peykova

Hi,

Thanks for letting me know.

0
avatar image
Former Member Dec 29, 2016 at 08:24 AM
0

Hi, Issue solved- I check the errors in CVI using t code- MDS_PPO2

The error happened because some mandatory fields in customer account groups are not filled correctly mainly the street and district in general data tab. If anyone experiencing similar issue should consider the field control of customer account groups and BP account groups it should be in line.

Share
10 |10000 characters needed characters left characters exceeded