Skip to Content
avatar image
Former Member

Problem applying SAP JVM 4.1 patch 20

Hello experts,

I am running NetWeaver 7.00 portal on SPARC 64bit, Solaris 10 systems.  After the initial installation of SAP JVM 4.1.001, I have been able to apply patch 20 (4.1.020) on consumer and producer Sandbox servers.  However, I got this error in dev_server0 when restarting the Dev portal server:

Invalid layout of java.lang.ClassLoader at dependencies

The installation seemed to be ok.  The JVM version and location were correctly displayed; the dispatcher/SDM servers started ok, but not the application server.


Here is other information:

SBX consumer: NW 7.00 SP26, SAP kernel 720 p201, SAP JVM 4.1.020

SBX producer: NW 7.00 SP23, SAP kernel 700 p278, SAP JVM 4.1.020

Dev consumer: NW 7.00 SP23, SAP kernel 700 p278, SAP JVM 4.1.001

Any suggestions would be greatly appreciated.

Hung

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Apr 09, 2012 at 07:41 PM

    Hello experts,

    Actually, I found a solution for this problem. I was using the Wily (Introscope) connector that was compiled under the old JVM.  Re-compiling the connector jar or removing the Wily parameters (using the Configtool) will fix the problem.

    Thanks,

    Hung

    Add comment
    10|10000 characters needed characters exceeded