Skip to Content
author's profile photo Former Member
Former Member

BAPI_SALESORDER_CHANGE Problem

I try to update "ORDER_TEXT":

SALESDOCUMENT='0000014020'

ORDER_HEADER_INX-UPDATEFLAG='U'

ORDER_TEXT-DOC_NUMBER='0000014020'

ORDER_TEXT-ITM_NUMBER='000000'

ORDER_TEXT-TEXT_ID='0001'

ORDER_TEXT-LANGU='E'

ORDER_TEXT-TEXT_LINE='Add text to head'

But I can't get the change.

Help me, Any idea?

Add a comment
10|10000 characters needed characters exceeded

Related questions

6 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jun 01, 2005 at 09:10 AM

    Thanks everyone.

    I just do "Test/Execute"

    I get the BAPI RETURN message:

    T ID NUM MESSAGE

    S V4 233 ORDER_HEADER_IN has been processed successfully

    S V1 311 Standard Order 14020 has been saved

    but "ORDER_TEXT" don't update.

    maybe set ORDER_HEADER_INX some fields?

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Tony,

      You need to issue the FM BAPI_TRANSACTION_COMMIT in the same LUW as your change BAPI.

      To do this create a FM "Test Sequence". Do this from Se37. Menu is: Function Module->Test->Test Sequences.

      You can then specify the two function modules and your changes will be applied to the database.

      Brad

  • author's profile photo Former Member
    Former Member
    Posted on Jun 01, 2005 at 08:35 AM

    Hi

    Do have set BAPI-COMMIT?

    BR

    Michael

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 01, 2005 at 08:37 AM

    Check the Bapi Return. If it is 'Sales order under processing' , Check all the Bapi Inputs and call BAPI_TRANSACTION_COMMIT after the bapi for sales order change.

    Thanks,

    Rehan

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 01, 2005 at 08:56 AM

    Hi

    Check the fields which you want to update and try..

    ORDER_HEADER_INX-UPDATEFLAG='U'

    Like this..

    ORDER_HEADER_INX-DOC_NUMBER='X'

    ORDER_HEADER_INX-ITM_NUMBER='X'

    ORDER_HEADER_INX-TEXT_ID='X'

    ORDER_HEADER_INX-LANGU='X'

    ORDER_HEADER_INX-TEXT_LINE='X'

    Thanks,

    Govind.

    Message was edited by: Govindaraju Ayyakkannu

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi govindaraju,

      Set the BAPISDTEXT-FUNCTION-Parameter in

      003 delete

      004 change

      005 replace

      009 First time

      023 do nothing

      018 send again

      See Dataelement: MSGFN => Value Range

      Hope I could help You

      BR

      Michael

  • author's profile photo Former Member
    Former Member
    Posted on Jun 01, 2005 at 08:36 AM

    Hi

    Do have set BAPI-COMMIT?

    BR

    Michael

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 02, 2005 at 07:02 AM

    The test successfully

    Thanks everyone

    Special thanks Brad Williams Michael Bauer

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Tony,

      No problems. Please remember to acknowledge those answers that helped you by awarding them points.

      This can be done by clicking on the the little stars next to each response in the thread.

      Cheers,

      Brad

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.