Skip to Content
0
Former Member
Apr 09, 2012 at 07:21 AM

Removing Compound Attribute in Filter selection

217 Views

Hello Experts ,

We have a problem with compund attribute in Filter selection.

We have characteristic 0GL_ACCOUNT it has a compounding attribute 0CHRT_ACCTS(Chart of accounts).

0CHRT_ACCTS 0GL_ACCOUNT

COFA 520000

COFA 600000

We have created variable on 0GL_ACCOUNT.

The requirement is we should not display COFA in Variable selection screen , Display Screen and in Filter in input help.

Variable selection screen , Display Screen we achieved by putting 0CHRT_ACCTS , 0GL_ACCOUNT in rows in the same order and no display option for 0CHRT_ACCTS.

But in Analyzer after exicuting the query when i select 0GL_ACCOUNT select filter value and i tried to give the values from single values/value ranges the input format is coming as COFA/520000 but the user wants to enter 520000 only , he dont want to enter "COFA".

I have tried to give restriction on 0CHRT_ACCTS = COFA but no use.

I have checked with all the options in BEX Query Designer only values in infoprovider , values in master data table , only posted values for navigation and the same for the infoobjects 0CHRT_ACCTS , 0GL_ACCOUNT also. But no use.

Similer problem with the 0FISCPER also..Since 0FISCPER has a compound attribute 0FISCVARNT when we want to enter the values in filter it is asking the value should be in format k4/001.2012 but the user wants the format should be 001.2012.

Please suggest what will b solution for this problem.

Thanks in Advance.

Ravinder Bhoga.