Skip to Content
author's profile photo Former Member
Former Member

Compression for BSP-Pages

Hello,

we've tried to use GZIP-compression on WAS 6.40 (compression was activated in the SICF) to reduce the bandwith which our customers need to access our web page smoothly.

Unfortuneately the GZIP seems not to work for our BSP HTML pages but other mime-types will get compressed without problems (same server).

e.g. for javascript-files we'll get "Content-Encoding=gzip" in the server-response for html-content we get no "Content-Encoding".

Any idea what could be the reason?

regards ... Fred

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on May 31, 2005 at 10:10 PM

    Where are you setting the GZIP in ICF?

    What we usually do is to set the checkbox on the properties page of (all) controllers and pages.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 01, 2005 at 11:10 AM

    Hi Brian,

    in the SICF there is an option called "compression (if possible)" for each service which we've set to true for each of our services.

    In each of controllers / sub-controllers we've set the compression in the "Tranferoption" to true.

    regards ... Fred

    PS: our Kernel:

    Component version: Netweaver 04

    Kernel-release: 640

    Compilation: HP-UX B.11.00 A 9000/800 Feb 8 2005 20:34:57

    Patch-level: 58

    ABAP-Load: 1521

    CUA-Load: 15

    PSS: General question: To get compression is it really neccessary to set the compression for all depending controllers of a request or is the main controller sufficent (in the current solution we've setup the flags for all depending controllers)?

    Add a comment
    10|10000 characters needed characters exceeded

    • Theorectically it should be sufficient to set the compression on the root controller.

      Keep in mind that compression is a best effort thing. There is no guarantee that it will be compressed. Two things to quickly check: are you using HTTP/1.1? Also check that there is a global ICM flag to disable compression for the complete server. Maybe you have this set?

      Another minor aspect: for very long URLs (> 255 bytes), compression is also disabled.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.