Skip to Content
0
May 30, 2005 at 02:58 PM

Copy command not working for Search Results

15 Views

Hello,

We have a Search Form that triggers a TREX URL search. We also add a custom Layout Set on the search URL. (see URL below)

<b>URL Search:</b>

http:
<server name> &ConfigFileName=Navigation.xml&layoutSetMode=exclusive&ResourceListType=com.sapportals.wcm.SearchResultList&SearchType=ctrlpers&QueryString=*&rndLayoutSet=CustomLayoutSet&SelectedMatchesPerPage=15&SearchVisible=false

In the custom Layout Set, we've made our own UI command group to include the following commands: Search_from_here, details, copy, move etc…

The problem is that whenever we click on the 'Copy' or 'Move' command of a resource, we get the following error message:

=====================================

Item not found

The item you are attempting to access is not available. Check that the name or link is correct. You might also check whether the associated repository is currently accessible.

======================================

The error message in the KM log files simply states "ERROR: RID not found".

Would anyone know how to fix this issue! I've tried many layout sets, but the copy command always gives me the same error message!

Any help or suggestions on this would be much appreciated...

Thanks,

Harman