Skip to Content
author's profile photo Former Member
Former Member

Problem with a Bex Report

Hi Friends,

In a Bex Report, when i executed it for the first time

it had upto 7 variables, in which i entered the input for 3 of the mandatory fields and executed the report,

now the problem is .... for the 3 variables which i entered the values , the query is not asking for input when i executed it for the second time( not showing them in the variable list) , it has taken the values which i gave for the first time , if i am executing the query it is showing thye result for the values which i entered for the first time ,

so i am not able to run the report for other values,

But the same report is working fine in my friends login,

Please suggest me how i can make those variables again in my variable list ,

Thanks for any suggestions,

Raky

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • Best Answer
    Posted on May 30, 2005 at 02:14 PM

    Hi rakesh!

    Welcome to sdn...

    Its might be because of personalization of the values in Bex analyzer. once opened a query you can change the values of vriable by selecting the option "change variable values" under the "change query ".

    there you can see the option to personalize the value( which is shown with the symbol with a face or ctrl+F8) i think it asks you to delete the old values if you already have a personalization for this variable.

    it must work...

    (award points to helpful answers .....)

    with regards

    ashwin

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 30, 2005 at 02:08 PM

    Hi,

    Have you checked that the variables have been defined as "Ready for input".

    With rgds,

    Anil

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 30, 2005 at 02:24 PM

    Hallo

    If you got some personalitation, you do not get again the Variable. In this case, go to Change on the Bex Bar and select Change Variable Values. In this case, all the Variables Pop up turn on.

    Regards

    Mike

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 30, 2005 at 02:37 PM

    What you have done is , you have set up personalization. That is the reason why the input is not being asked.

    Set the option as mandatory input in variable definition.

    Arun

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.