Skip to Content
author's profile photo Former Member
Former Member

XI 3.0 and ECC 5.0 IDoc definitions

We use XI 3.0 fo extensive integration with SAP. We recently upgraded from 4.7 ES 2.00 to ECC 5.0. The problem is that all IDoc developments we do now, is recorded as version 640, but XI still thinks the system runs on WAS 620. XI still uses the "old" 620 IDoc definitions missing all the new developments. There is no installed product entry for the new ECC 5.0 in XI. I assume one has to import new application components into XI so that XI is now also aware of ECC 5.0? Is this true and if so, where would we get those new components?

Thanks for the help.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    Posted on May 30, 2005 at 08:51 AM

    Hi Johan,

    - if then new IDOCs have new signatures (some new fields) you can import them again in Repository and use the new ones in all mappings/message interfaces etc.

    - also try removing old definitions (idoc metadata) in TCODE IDX2 - and upload new

    (you don't have to do it because it should upload when you first you the new IDOC type but...

    you can try doing it to see if you got the new IDOC definition)

    IDX2:

    - click Create

    - specify idoc type and RFC port to your ecc 5.0

    - and check if this is the idoc type taht you want

    BTW you specify RFC port for loading idoc metadata in IDX1

    - you can also set <b>SAP release</b> parameter in IDOC communication channels

    Regards,

    michal

    Message was edited by: Michal Krawczyk

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Michal,

      Thanks fo the reply. I meant to thank you a few days ago already, but we had connectivity problems and I couldn't post on SDN.

      Your suggestions helped me solve the problem. The IDX2 metadata definitions had to be deleted and once they were automatically re-created with the first message, it solved my problem.

      Thanks again for solving something that gave me headaches for quite a few days.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.