Skip to Content
avatar image
Former Member

AVC warning message does not working when save as complete

Hi FM Experts,

I have a problem when save as complete journal manual. There is AVC warning message if the budget reach more than 80%, but it's not working.

I already maintained the value type for save as complete and the tolerance profiles.

There are 2 condition if I try to post the journal manual:

a. First condition: I want to post journal manual USD 900.

- Available budget: USD 1000

- Consumed amount: - (not yet transaction related budget)

- Available budget: USD 1000

There is no AVC message appear until I post the document.

b. Second condition is the same like first condition, but there was transaction related budget before.

- Available budget: USD 1000

- Consumed amount: USD 200

- Available budget: USD 700

AVC message appear when I want to post the document, not when save as complete.

How can it happen? Does It because of the setting?

FYI: we use SAP release 604, package 10 for EA PS.

We tried sapnote 1165926, it doesn't relevant and 573409 which didn't affect anything.

Thanks before 😊

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    Mar 29, 2012 at 07:50 AM

    Hi

    As u mentioned 'save as complete' means you are parking document or else posting the parked document.

    While posting of park the doucment system will not check budget and consumed the amount. But at the time of posting the parked document system will check the Budget AVC and consumes the amount.

    If this is not the case let me know with detailed information.

    Regards

    Rao

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi KTP Rao,

      What is the standard system response when a parked document exceeds the budget. For me system is not throwing any error and just warning and is not allowing to park.

      Is it possible to control through error message

      Thanks

  • Mar 29, 2012 at 09:37 AM

    Hi,

    What update profile do you use in FM? Check if VT 60 is not defined as 'statistical' in your profile.

    Regards,

    Eli

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 29, 2012 at 09:53 AM

    Hi Mr. Rao,

    Before I already read that forum. And the sapnote mentioned from the forum, it didn't affect anything.

    My project before, when I save as complete the parked document, the AVC warning message appear based on the tolerance profile.

    With the same setting, there is no AVC message when I click the 'save as complete' button.

    Could it be because of the period based or FY based in value type? Because it's different with my project before.

    Hi Mr Eli.

    Update profile is 000101.

    Thanks before 😊

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi

      In continuation of my previous reply, also I would like to know this problem u are getting at the time of MM parked invoice posting? or also FI parked document posting?

      And also could pls share the OFUP GR/IR settings.

      Regards

  • avatar image
    Former Member
    Mar 29, 2012 at 11:49 AM

    Hi

    In continuation of my previous mails I am sharing some useful information on this issue:

    1. While posting of parked invoice document system will not check Budget and also FM doc will not generate. (Parked doc posting thru FBV0 or FBV2). Budget check will happen only posting of parked doc.

    2. But coming to MM parked invoice (say thru MIR4 ) if u click on 'save as completed' option system checks the budget avc and also FM document will be generated. But Accounting document will not be generated. Account doc will be generates only if click on 'Post' option. Here budget warning messages will not generate.

    3. Budget check and FM document generation happens only based on your OFUP GR/IR settings. In your case may be commitment item is not budget check relevant.

    Hope this will help to resolve your issue.

    correct me if anything wrong.

    Regards

    Rao

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Mr Rao.

      I tried the following posting process you mentioned before. The results are:

      1. Park journal through FB50. save as complete by FBV2 and the warning message nor the mail doesn't appear. But, when post it with FBV0, the warning message appear without mail.

      2. Park journal through FB50 and then post it (without save as complete) in FBV0, the warning appear. And when click 'Back' button, the mail pop-up appear and bring us to the SBWP.

      3. Park invoice in FB60 and save as complete in FBV2. The avc message doesn't appear, but when click 'Back' button, the mail pop-up appear. When post through FBV0, there's just warning message.

      So, based on your description about posting process compared to my process:

      - Condition (1) is true and same with my process.

      - Condition (2), the warning message doesn't appear. Based my experience in project before, the avc message appear when save as complete if maintain value type 60 (save as complete).

      - Condition (3) is same with my process. The avc so far just appear when post document.

      - Condition (4) is same with my process.

  • avatar image
    Former Member
    Mar 29, 2012 at 11:53 AM

    Hi

    I tried FMAVCDERITPROF as Mr Eli said, it works.

    System read the tolerance profiles from standard SAP, not from our own setting.

    I dont know how it can be happen. So I try to maintained the standard.

    The warning message appear by mail SBWP.

    In the tolerance profile, I set the warning message with mail. The warning message doesn't appear but there's pop up that bring us to SBWP.

    How the warning message can't be appeared?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      In the setting of assigning tolerance profile to the AVC ledger, did you also assign a 'strategy for deriving teolerance profile'? If so, that derivation strategy will overwrite the tolerance profile you assigned to the ledger and you should use FMAVCDERITPROF to maintain that strategy.

      If you only use ONE tolerance profile, then, just assign it to your ledger but NEVER assign any strategy to the ledger.

      Regards,

      Ming