Skip to Content
0
Former Member
Mar 28, 2012 at 08:10 PM

bytecode adapter installation failing on authentication error

67 Views

Hi,

We have upgraded to solman 7.1. While working through managed system configuration, I've hit the step for bytecode adapter installation which fails on an authentication error. An excerpt of the SMDAgentApplication.X.log below indicates that the problem is going to the managed system. It isn't clear what userID it is attempting to use. I tried creating the userID, SMD_ADMIN, that was specified in smdsetup managingconf on the managed system, but that doesn't appear to be the correct ID.

Does anyone have any suggestions or experience?

Mar 28, 2012 3:38:19 PM [Thread[Thread-303,5,main]] Error P4 connection error to SAP system [SB1/00]

[EXCEPTION]

com.sap.engine.services.jndi.persistent.exceptions.NoPermissionException: Exception during getInitialContext operation. Wrong security principle/credentials. Root exception is com.sap.engine.services.security.exceptions.BaseLoginException: Cannot authenticate the user.

Thanks,

Russ

Message was edited by: Russell Brooks I suspect the userID used is SM_COLL_SM1. While the user has a green light and the message "User exists with recommended roles", a test of the ID shows the following dump: An error occured while processing the UME command READ_USER from agent sapbisb : com.sap.engine.lib.xml.parser.ParserException: XMLParser: No data allowed here: (hex) 6a, 61, 76(:main:, row:1, col:41)(cause=com.sap.engine.lib.xml.parser.ParserException XMLParser: No data allowed here: (hex) 6a, 61, 76 (:main:, row:1, col:41)) : com.sap.engine.lib.xml.parser.ParserException: XMLParser: No data allowed here: (hex) 6a, 61, 76(:main:, row:1, col:41) I've tried creating and assigning role Z_SPML_ADMIN to SM_COLL_SM1, but that does not fix it.