Skip to Content
author's profile photo Former Member
Former Member

500 Internal Server Error B1i 8.82 PL04

Hello,

I have installed SAP B1 8.82 PL04 and have problem with activating widgets. Integration component is installed correctly. In SLD connection to my database at B1DI and JDBC works fine, but in SAP I receive this message:

SAP B1iP detected an error:

Emitted HTTP-Code

500 - Internal server error

Internal reason:

Did not supply an appropriate user-ID integer (Param6)

Can anyone help me with this problem?

Regards

ES

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Posted on Mar 30, 2012 at 05:21 AM

    Try upgrading to PL05. I always had issues before this patch level. Even better upgrade to 8.8.2, it works like a champ. Also take a look at the administration guide for the Integration Component for a trouble shooting guide.

    Edit: OOPS my bad. I thought 8.8.1 PL04.

    Check out the trouble shooting notes

    https://websmp230.sap-ag.de/sap(bD1lbiZjPTAwMQ==)/bc/bsp/sno/ui_entry/entry.htm?param=69765F6D6F64653D3030312669765F7361706E6F7465735F6E756D6265723D3136313934323226

    The following Note has links to all the trouble shooting guides

    https://websmp230.sap-ag.de/sap(bD1lbiZjPTAwMQ==)/bc/bsp/sno/ui_entry/entry.htm?param=69765F6D6F64653D3030312669765F7361706E6F7465735F6E756D6265723D3134393535363326

    1.6 Error HTTP 500 – Internal Error

    • Root cause 1: The dashboard is not deployed correctly in B1ic for the selected company or may have encountered an error.
    • Solution 1a: Ensure the correct company database appears in the SLD. Deactivate and re-activate the dashboard in SAP Business One’s General Settings.
    • Solution 1b: Check the Message Log in the Integration Framework -> Monitoring for errors (Failure) connected to “Sender Trigger / Object” “500” (event to create SLD entry) or “120000008” (event to deploy dashboards)
    • Solution 1c: Check the Queue Monitor in the Integration Framework -> Monitoring for pending processes – after installation / upgrade some post-installation processing time may be required (depending on various factors up to 2 minutes per B1 DB on slow systems)
    • Solution 1d: Go to the B1iP Control Center -> Maintenance -> IPO-Step Status and check “Deactivated steps only" to check whether any processes are halted. If so, the relevant error may be displayed – giving a hint for details that require fixing.Activate the deactivated steps – and press “Refresh” to see whether the steps can successfully be reactivated. If the step cannot be activated, then please deactivate the integration scenario (Scenarios – Control and untick the scenario package for sap.Xcelsius). The you should be able to activate the IPO steps and afterwards the scenario package needs to be activated again.
    • Root cause 2: The JDBC URL is incorrect as the company was created manually with incorrect information.
    • Solution 2: Ensure the correct Server/port and database details have been entered in the JDBC URL

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Jeff,

      I have also encountered the same HTTP 500 error. I am on SAP B1 8.82 PL6.

      Tried all the stuff you have mentioned here still no success. Can you please let me know what else can be done to avoid this error.

      Reply urgently

      Regards

      Sonil

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.