Skip to Content
avatar image
Former Member

Unable to load URL - error when load webservice wsdl

Hey.
 
I already have following error. I created an SAP webservice and copied the URL of the WSDL in the dashboard webservice connection field. But when I press the button import, I got th error "unable to load URL". But when I test the URL in the browser, it works.
The URL needs an authorization is this a problem?
 
I also testet the webservice connection with an java webservice on my local tomcat webserver. There it works!
 
Thansk.
 
BR,
Christoph

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Mar 21, 2012 at 04:44 PM

    Is your domain fully qualified?  You may need to check to make sure you aren't leaving off the qualification (myBOServer.my.server.com).  Also, try inserting the IP in place of the host (http://<IP Address>:<port>/dswsbobje...).

    Regards,

    Kevin

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 25, 2012 at 03:43 PM

    Also check the note below:

    SAP note: 1240174

    Symptom

    • Error: "Unable to Load URL" when trying to add a Web Service Connection in Xcelsius.
    • The WSDL is based on multiple schema i.e. one schema imports from the other.


    Environment

    • Xcelsius 2008 Enterprise
    • Xcelsius 2008 Enterprise Service Pack 3


    Reproducing the Issue

    Try to load http://jira.atlassian.com/rpc/soap/jirasoapservice-v2?wsdl as a web service connection inside Xcelsius.


    Cause

    This behaviour is noted in ADAPT01454514.


    Resolution

    Xcelsius is designed to consume simple single schema Web Services. The ability to consume Multiple Schema basd web services can be considered as an enhancement request in Xcelsius.

    The acceptance enhancement request, inclusion of additional features in a product and its related timeline lies at the sole discretion of the Product Group.

    Thus, issue may (or may not) be fixed in a future Service Pack / Fix Pack.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hey Zahid,

      sorry for the late response - wasn't in the office for the last days.

      I got the same error you described in the note above, but didn't know what to do now against the error. How did your abap guy implement the webservice?

      Thanks for your response.

      best regards,

      Christoph

  • avatar image
    Former Member
    May 22, 2012 at 11:35 AM

    I had a similar problem and I found out that I didn't finish my web service configuration in SOAMANAGER.

    After generating the web service you need to create a binding in SOAMANAGER please see this guide:

    http://scn.sap.com/people/mohan.kumark/blog/2008/10/14/soamanager-how-to-test-service-definition-using-soamanager-transaction

    Multi-schema issue should not be related to this SAP web services. Since I also have a WS generated from a FM in SAP CRM. And it works now!

    Seems to me this will solve your problem.

    Cheers,

    Armands

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 28, 2012 at 10:42 AM

    Try this,

    1. Copy URL in IE Brower only.

    2. Save file as XML.

    3. Open Xml file with notepad.

    4. find & replace

       Find <soap:operation style="document"/> Replace <soap:operation soapAction="" style="document"/>

    5. save file.

    6. import in xcelsius

    (for more detail check U10_How_to_Guide_EN in SDN)

    Add comment
    10|10000 characters needed characters exceeded