Skip to Content
author's profile photo Former Member
Former Member

Rfc data in my custom controller context but not in my view

Hi all,

I'm trying to develop a web dynpro accessing bapi.

I successfully execute the bapi and get the data in return. In debug mode, if I set a break point after the execute method of the custom controller, I can see my data under the JCO Record node.

My problem is that I do not succeed in displaying the result in my result view.

I create a context for this view, map it with the custom controller context, and I add a table in my view to display the result on which I use "create binding" to tell the table what to display.

Still, the table did not display anything (no error but no data !)

Does anyone can help me ?

Thanks

Sylvain V

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on May 26, 2005 at 04:11 AM

    Hi Sylvain,

    You said you can execute BAPI successfully but it don't show results on view.

    Did you invalidate your output nodes after executing bapi?

    If no then invalidate all your output nodes like this:

    wdcontext.nodeOutput.invalidate();

    wdcontext.node<output node if any>.invalidate();

    Then try once again.

    Let me know the status.

    regards,

    Bhavik

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 25, 2005 at 02:19 PM

    Hi

    Just Check ur Mapings and before that try to print reportSucces from Custom Controller itself where u r getting the data

    If u r getting the data in Custom controller then the problem shuld be in your mapping other wise ur model binding is not proper

    With Wishes

    Krishna kanth

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 25, 2005 at 02:13 PM

    Are you sure that you are binding to the same ContextNode in the customController ??

    Regards, Anilkumar

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.