Skip to Content
author's profile photo Former Member
Former Member

Switching between clients - Integration builder

Hi,

I'm trying to set up specific business scenarios between different clients on our R/3 qas server. Using integration builder, each interface was defined as having either sender / receiver clnt100 and clnt401. Tests have been performed successfully on both clients vs. our legacy system.

Recently, it has become necessary to remove interface data coming from / going to client 100. I've removed the necessary definitions in the business scenario configurations. This has worked fine : tests outbound from client 100 are not being processed. However, I'm having trouble with the link between the IDoc interfaces and the processing of the messages for the remaining client. Each message type, such as (ZZ)CREMAS or (ZZ)MATMAS is defined correctly, and we have periodic jobs setup that run a specific program with an associated variant.

Ex : Job SEND_VENDOR_CP runs (successfully) every minute (with an associated message type). However, the data isn't being pulled. I have to manually start the job. This then results in a message being sent through (sxmb_moni - message with "checkered flag") and the legacy system receives the data from this client (401) normally. I'm just wondering why the interfaces don't run automatically in client 401 (as they still do in client 100). Is there a missing association in the message types ?

Any help would be greatly appreciated (I'm fairly new to XI). We are using XI 2.0. Our systems are defined as :

XIQAS000 (1 client) EQ1CLNT100 & EQ1CLNT401 (same for the RFC's).

Thank you,

Eric P.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on May 25, 2005 at 02:46 PM

    Found the problem : the scheduled jobs on 401 were targeting client 100. Re-creating the background jobs has solved this problem.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.