$(function () { pageContext.i18n.modTalk = 'moderation talk'; pageContext.i18n.replyToComment = 'Reply'; pageContext.i18n.modTalkEmpty = 'moderation talk is empty'; pageContext.url.getModTalk = "/comments/%25ID%25/listModTalk.json"; pageContext.url.possibleCommentRecipients = "/comments/%ID%/possibleRecipients.json"; pageContext.url.commentEdit = '/comments/%25ID%25/edit.html'; pageContext.url.commentView = '/comments/%ID%/view.html'; pageContext.i18n.commentVisibility = { 'full': 'Viewable by all users', 'op': 'Viewable by the original poster', 'mod': 'Viewable by moderators', 'opAndMod': 'Viewable by moderators and the original poster', 'other': 'Advanced visibility', 'dialogTitle': 'Comment visibility', 'selectGroups': 'Visible to groups', 'selectOther': 'Other recipients', 'selectOriginalPoster': 'Original poster', 'selectModerators': 'Moderators', 'selectAssignees': 'Asked to answer users' }; pageContext.i18n.commentMenuLabels = { 'comment-edit': 'comments.menu.edit', 'comment-delete': 'comments.menu.delete', 'comment-convert': 'comments.menu.convert' };pageContext.i18n.answer= { bestAnswer: 'Best Answer', controlBar : { accept: 'Accept', unaccept: 'Unaccept', acceptCommand: 'Accept this answer as correct', cancelAcceptedCommand: 'Remove this answers accepted status' } }; window.croles = { u: false, op: false, m: false, og: false, as: false, ag: false, dc: false, doc: false, eo: false, ea: false }; tools.init({ q: { e: false, ew: false, eo: false, r: false, ro: false, d: false, dow: false, fv: false, c: false, co: false, p: false, tm: false , ms: false, mos: false }, n: { f: false, vf: false, vfo: false, vr: false, vro: false, c: false, co: false, vu: false, vd: false, w: false, wo: false, l: false }, c: { e: false, eo: false, d: false, dow: false, ta: false, tao: false, l: false }, a: { e: false, ew: false, eo: false, d: false, dow: false, a: false, aoq: false, ao: false, tc: false, tco: false, p: false, tm: false }, pc: croles }, { tc: true, nsc: true }); commandUtils.initializeLabels(); }); Skip to Content
0

Variant is disabled in smart filter bar and table

Dec 27, 2016 at 08:39 AM

835

avatar image
Former Member

Variant is disabled for botht smart filter and smart table.
I have chked below services are activated in SICF and console is showing the error "Component-changes.json could not be loaded".

/SAP/BC/UI5_UI5

/SAP/BC/LREPissue.pngconsole.png

issue.png (9.8 kB)
console.png (30.6 kB)
10 |10000 characters needed characters left characters exceeded

Hi Radek,

I was also facing the same issue but when I deployed to backend, its working now. But when I am saving some data(values in the filter criteria) in a new variant, only the variant name is getting saved but not the data. When I load the application again, only the variant name is coming as part of variants list but not the data in fields. Can you help me in solving the issue that why the data is not getting saved. My current library version is 1.38.14.

Is there any note or upgrading the library version will solve the issue?

0
* Please Login or Register to Answer, Follow or Comment.

9 Answers

avatar image
Former Member Feb 15, 2017 at 05:17 PM
1

From where you are trying to access the app? if you try to work with variant management from WEBIDE or Eclipse it wont work.

You need to deploy it to launch pad to work with variant management


vm.jpg (57.8 kB)
Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Feb 13, 2017 at 12:11 PM
0

Hello,

whether this issue is solved.?

I am also facing same problem.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Feb 15, 2017 at 05:32 PM
0

Hi All

I am facing a similar issue where the Variant button is disabled. Please refer to the below screen shot

variant.png

Below is the code I am using for displaying Smart table

<smartTable:SmartTable id="LineItemsSmartTable" entitySet="LineItemsSet" smartFilterId="smartFilterBar" tableType="ResponsiveTable" useExportToExcel="true" editable="false" useVariantManagement="true" useTablePersonalisation="false" header="Entities" showRowCount="true" enableAutoBinding="true" persistencyKey="SmartTablePkey"


variant.png (266.6 kB)
Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

As Basavaraja Goudar said it won't work unless you deploy it to the FIORI Launchpad. You are running it in eclipse on local server.

0
avatar image
Former Member Feb 22, 2017 at 04:00 AM
0

Hi Radek

I tried deploying the app to the FIORI Launchpad, still the variant is disabled . Please refer to the below screen shot.

Thanks

Asmita


untitled.png (163.4 kB)
Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Did you get a resolution to this?

0
avatar image
Former Member Apr 06, 2017 at 08:51 PM
0

Did you get a resolution to this?

Share
10 |10000 characters needed characters left characters exceeded
Lakshmi Sachidanandam
May 22, 2017 at 09:59 AM
0

Even i faced the same error and got it working after deploying to launchpad.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member
Jul 11, 2017 at 04:52 PM
0

Even me too facing the same issue, any one can give me a solution?

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jul 25, 2017 at 01:00 PM
0

If you start the developers tool(F12) you will see there is an error referring to missing component-changes.json. Add this file to your project at the same level as the Component.js file. Then add below config to the file:

{ "changes": [], "settings": { "isKeyUser": true, "isAtoAvailable": true, "isProductiveSystem": true } }

This way the variant button should be enabled.

Share
10 |10000 characters needed characters left characters exceeded
Patrice PALAZZOLO
Jun 28 at 02:58 PM
0

Hello,

I had similar issue where the variant where disabled but somehow working within the LaunchPad. I had a look at the code and find out that the SmartVariantManagement is calling Utils.js method: _getAppComponentForComponent - in order to get an AppComponent

		/**
		 * Returns the Component that belongs to given component whose type is "application".
		 *
		 * @param {sap.ui.base.Component} oComponent - SAPUI5 component
		 * @returns {sap.ui.base.Component} found component
		 * private
		 */
		_getAppComponentForComponent: function (oComponent) {

                 ......
                 if (oSapApp && oSapApp.type && oSapApp.type !== "application") {
				//we need to call this method only when the component
				//an instance of Component is in order to walk up the tree.
				if (oComponent instanceof sap.ui.core.Component) {
					oComponent = this._getComponentForControl(oComponent);
				}
				return this.getAppComponentForControl(oComponent);
			}


			return oComponent;
		},

My component was declared as type: "component" but then i've switched to type: "application" - the variant management started to work. So it looks like in order to be enabled, the variant management needs to find an AppComponent.

Hope this will help.

Patrice.

Share
10 |10000 characters needed characters left characters exceeded