Skip to Content
0
Former Member
Mar 14, 2012 at 08:54 AM

Analysis Authorizations on BO Explorer

34 Views

Hi all,

I am trying to use Analysis Authorizations in Accelerated BO Explorer. I have tried a number of things but I either see all or nothing of the Info Space (based on queries). I have tried the following:

  1. Assign the authorization object to the role and have 0BI_ALL in RSDDTPS
  2. Assign the authorization object in RSDDTPS
    • I then get an error message after activation that reads "Authorization ZPAYROLL_01 causes user BWTESTUSER to not have any authorizations"
    • I can also confirm that the auth object weren't added to the index created if I look at the TREX Admin Tool (TREXADMIN)

I found very little documentation that explains the workings of Analysis Authorizations and the BO Explorer but I could confirm (in one document at least) that it is possible to restrict the user with AA to see only data slices for authorization objects based on a characteristic. The one thing that I'm unsure about is that all the sample scenarios I could find uses AA with Info Providers - not queries.

I'd appreciate any input that can send me in the right direction.

Thanks