Skip to Content
0

Disable a field which is managed by GUIXT script in VA02 transaction.

Dec 27, 2016 at 06:54 AM

99

avatar image

Hi ,

I need to disable a field (payment term )which is managed by Active GUIXT script in VA02 transaction.

    In Doc.header under tab Header add We have a payment term Filed which need to Be Grayed out for Some purchase organizations.

    10 |10000 characters needed characters left characters exceeded

    Hi .

    Kindly help me out in this issue its very Urgent.
    Please help me.

    0
    * Please Login or Register to Answer, Follow or Comment.

    1 Answer

    Sandra Rossi Dec 30, 2016 at 08:18 AM
    0
    Show 4 Share
    10 |10000 characters needed characters left characters exceeded

    Hi Rossi,

    Thanks for your reply. In the script file generated i have already tried this option by setting NoInput for the require field. But, still the field is editable.

    i have downloaded the script file from SMW0 (T-code), did the changes to the field and uploaded again.

    Can you guide me, if am missing some thing here to make the field as non-editable.

    do we need to change the field property through GUI designer tool?

    0

    How SMW0 is related to GuiXT? You should make it via a screen variant and a transaction variant (transaction SHD0). The only "GUI designer" I know is the "screen painter", but you don't need to do a modification of the standard, a screen variant/GuiXT is okay. But are you sure GuiXT is activated on your laptop and on users laptops too?

    0

    Hi Rossi,

    Iam working on 4.6 Version system where I don't have any

    GUI designer / Script page . so there are some custom script pages available in Smw0 (T-code) . so I have Modified script pages and Uploaded back . But this is Not working. actually am unable to find the sub screen or Filed name after activating Guixt.

    0

    Sorry, I give up, this version is really too old for me ;-)

    0