Skip to Content
author's profile photo Former Member
Former Member

Data load along with analyzation

Hello,

We had a data inconsistency situation and ran RSRV tests. One of the tests is INITIAL KEY FIGURE UNITS IN FACT TABLES. This test gave a red light giving the message "RESULT OF CHECK FOR KEY FIGURE UNITS IN FACT TABLES OF INFO CUBE "ZXXXXX" ARE EMPTY.

The description is as follows:

Message no. RSRV117

Description:

In the fact tables (E and F tables) of an InfoCube, a search is being carried out for those records that contain values other than zero for key figures that have units, but for which the unit of the key figure is blank (has no value).

Since the value of the unit has to correspond to the value of the key figure, such records would indicate an error in the data upload. The values of the units have not been loaded correctly into BW.

Repairs

There are no automatic repair options. Reload the data.

SO do I need to load all my data once again. Is this error because the data coming from R/3 has no units? Do I need to correct anything in the infocube before loading data? Also can somebody give me a link or documentation for step by step procedure for extraction and loading from R/3 to infocube at the same time analyzing the data load at each step?

Thank you

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on May 24, 2005 at 04:41 AM

    When you load data from R/3 for a quantity the extractor would not be created without a unit variable. check your extractor and transfer structure.

    And if you are assigning units to a separate quantity then you have to assign units manually using a routine in transfer rules.

    Arun

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Visu,

      As I understand what he meant is to check the fields in the Extractor that are populating the Currency Key fields that you specified in BW.

      If you have a 1-1 mapping in your Transfer structure;

      Run the Extractor in RSA3 on R/3 side for the records which have no units comming in.

      And then in the output display make sure that those fields are being populated.

      If you are using Transfer rules to pupulate those fields debug the transfer rules to find out why you are not getting the units populated correctly..

      Let us know ..

      Ashish.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.