Skip to Content
author's profile photo Former Member
Former Member

Client Proxies : "INTERNAL.PROXY_NOT_ALLOWED_ON_IS "

Hi,

Problems again in Proxies :-((

I went to sproxy transaction and generated the proxy. Now when i try executing it, it gives me the error :

<CODE>INTERNAL.PROXY_NOT_ALLOWED_ON_IS</CODE>

<ERRORTEXT>Proxy calls on the sender or receiver side are not permitted on the IS (client)</ERRORTEXT>

I understand that this error comes when i execute the proxy in the IS. But i have created a new client and am

exeuting the proxy in it... still i am getting this error.

kindly help me out...

Regards,

sonali.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

8 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on May 20, 2005 at 04:29 PM

    Hi,

    Did u register the queues after creating a client copy..?

    In the client system, Go to sxmb_adm > manage queues > register the Queues.

    Hope this solves your problem... 😊)

    Cheers,

    Siva Maranani.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 20, 2005 at 03:52 PM

    Hi,

    go to TCODE : sxmb_adm -> integration engine configuration

    and check if your new client is set as an <b>application server</b> and not integration server, maybe this will help

    Regards,

    michal

    Message was edited by: Michal Krawczyk

    Message was edited by: Michal Krawczyk

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 20, 2005 at 03:53 PM

    Hi,

    Are u sure you have executed the proxy in Client that you have created..? Check it once again..

    Try looking into the Integration engine settings.

    Can u tell what are the global configuration settings in sxmb_adm -->IS configuration. Mention the role of business system as "application system".

    Cheers,

    Siva Maranani.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 20, 2005 at 04:04 PM

    Hi,

    Yes i have made the mistake... i have mentioned it as a "Integration server", Now i have changed it...

    hurray!!....It Works....This answers have come at lightening speed... SDN XI-Forum is really super.

    Thanks michal & siva.

    Regards,

    sonali.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 20, 2005 at 04:23 PM

    Hi,

    It seems the errors are haunting me..... :-((

    I have executed the proxy and the i get the message that : "Services Processed Without Error" in client(105).

    But when i go to sxmb_moni(in IS), i could see a green colour flag.. which states "message waiting in queue".

    i have no clue why messages wait in queue... But the other scenario ( file-to-file) is working fine.

    --sonali

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 20, 2005 at 04:39 PM

    Hi Michal & Siva,

    Thankx for ur speedy help.

    I could successfully complete ABAP Client Proxies..

    Hope u will be there to help me tomorrow( on a week-end rite..). anyhow...N'joy ur weekend.

    Sonali.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 06, 2006 at 09:30 PM

    Hi sonali and all,

    I have the same problem as you had, but I am missing one part, I don´t really understand what you meant or how to do that when you said:

    "I understand that this error comes

    when i execute the proxy in the IS

    . But

    i have created a new client and am exeuting the proxy in it

    ... still i am getting this error."

    Hope somebody can help me

    Carlos

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 10, 2007 at 06:45 AM

    Thank you very much everybody. I got solution from this thread as well... 😊

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.