Skip to Content

Lote de NFe com erro, não reprocessa e não retorna para ECC

Boa tarde,


Estamos com uma situação no GRC onde o lote aparece com erro, não é reprocessado automaticamente e não retorna para o ECC, ficando parado, e a solução está sendo entrar no monitor do GRC e re-iniciar o lote manualmente.

Pelo monitor de status, o serviço estava ok no momento do erro.

Lotes antes e depois de um lote com erro são processados e finalizados normalmente, ou seja, o erro é esporádico, intermitente.

O lote só é aprovado depois de intervenção manual. No último caso o lote foi enviado as 10:15, o retorno do erro aconteceu as 10:18 e foi reprocessado manualmente e aprovado as 10:26.

Eu consegui pegar no GRC as mensagens pelo ID que aparece no monitor, neste caso meu conhecimento não é muito grande, então não sei se peguei as mensagens certas e só consegui identificar o erro abaixo, que não sei se é o erro propriamente dito, XML completo está em anexo.

- <SAP:Error SOAP:mustUnderstand="1" xmlns:SAP="http://sap.com/xi/XI/Message/30" xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/">

<SAP:Category>XIAdapter</SAP:Category> <SAP:Code area="BPE_ADAPTER

">NEGATIVE_ACKNOWLEDGEMENT</SAP:Code> <SAP:P1 /> <SAP:P2 /> <SAP:P3 /> <SAP:P4 /> <SAP:AdditionalText /> <SAP:ApplicationFaultMessage namespace="" /> <SAP:Stack>Negative acknowledgment triggered by a process</SAP:Stack> <SAP:Retry>M</SAP:Retry> </SAP:Error>

Já verifiquei os jobs escalonados conforme esse link e parece estar tudo certo.

https://help.sap.com/saphelp_nfe10/helpdata/en/5f/2084170058419aa05694e4d87d7b71/content.htm

Estava vendo o post do link abaixo, essa solução acho que me atenderia, criar um job que reprocesse os lotes parados, mas ainda preciso identificar a causa do problema.

https://answers.sap.com/questions/68428/existe-algum-programa-standard-para-reprocessar-lo.html

Também encontrei um programa no nosso ambiente, criado pelo Fernando Da Ros, e não sei se seria para este tipo de situação, mas acho que foi para atender uma Customer message específica como consta no cabeçalho do programa. Segue em anexo o programa completo.

Finalizando, segue minhas dúvidas:

1- Onde eu consigo ver exatamente o erro que ocorreu neste lote?

2- Qual solução paliativa seria melhor indicado para o reprocessamento destes lotes com erro, tipo um job periódico, para que não precise intervenção manual?

Obrigado

César

Versão dos ambientes:

SSL-NFE versão 9, SP 23

SAP_APPL versão 606 SP 7

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Feb 14, 2017 at 04:11 PM

    Bom dia Cesar

    Nós temos o mesmo erro, Você tem alguma idéia de como resolver este problema?

    Eu estava pensando em um programa "Z" para reenviar os lotes presos, mas nós também queremos encontrar a causa raíz d problema.

    Obrigada.

    Atenciosamente,

    Yolima Andrea
    Add comment
    10|10000 characters needed characters exceeded

    • Yolima, boa tarde,

      O que descobrimos até agora parece ser problema de link, conexão mesmo.

      Se for link mesmo não tem o que fazer, foi um problema pontual naquele instante, um reiniciar instantes depois resolveria, ou no caso um job automático.

      Estamos fazendo um teste em QA sem usar lote, emitindo a NFe individualmente em processo síncrono, parametrizado no GRC.

      O problema é que em QA o volume é pequeno para definir se vai resolver ou não.

      E se o problema for link o erro também vai ocorrer nesse processo síncrono.

      Acho que vamos colocar uma filial pelo processo síncrono em PRD para avaliar melhor.

      Att

      César

  • avatar image
    Former Member
    Feb 14, 2017 at 04:39 PM

    Boa tarde, Cesar!

    Tudo bem?

    Sua empresa tem um servidor PI exclusivo para NFe ou é um servidor compartilhado com outras aplicações? Além disso, qual a versão do ECC, GRC e PI que vocês utilizam?

    Obrigada!

    Att, Aline Ferraz

    Add comment
    10|10000 characters needed characters exceeded

    • Aline,

      O servidor é exclusivo para NFe.

      Versões dos ambientes:

      ECC - 606 SP 7

      PI - 702 SP 12

      SLL-NFE release 900 SP 23

      O que descobrimos até agora parece ser problema de link, conexão mesmo.

      Mas o que me incomoda é o lote ficar parado no GRC sem ter algum processo standard que reprocesse, tipo o programa /XNFE/NFE_CONTINUE_PROCESS.

      Manualmente, é só ir no PI e fazer um "reiniciar" que funciona, então acho que um job resolveria esses casos.

      Se for link mesmo não tem o que fazer, foi um problema pontual naquele instante, um reprocesso instantes depois resolveria.

      Att

      César