Skip to Content
avatar image
Former Member

DTR trying to connect using SSL

Hi experts!

I've configured NWDI on SAP NW 7.3, and i'm now trying to connect to DTR on NWDS. However, when i connect to my DTR system using HTTP, the response from the server is always a HTTP 302 (Found). I've switched on the logs on NWDS for DTR and every NWDI component, and then i've found that the server tries to switch protocols to https returning to the client (NWDS) a page with

<td valign="top"><PRE>Go to the temporary <a href="https://vmwin023:443/dtr/">https://vmwin023:443/dtr/</a>"</PRE></td>

On the server logs, i checked that the login is failing in security.log with a user Guest, instead of using the one i'm passing on NWDS. On defaulttrace logs there are no lines written, even when i switch the log configuration for the detail level "ALL" for DTR category.

Follows the only error that i found on the server:

LOGIN.FAILED

User: N/A

IP Address: <<my local machine ip address>>

Authentication Stack: sap.com/tcdtrenterpriseapp*dtr

Login Module Flag Initialize Login Commit Abort Details

1. com.sap.security.core.server.jaas.EvaluateTicketLoginModule SUFFICIENT ok false true

#1 trusteddn1 = CN=JD8,OU=I0020406197,OU=SAP Web AS,O=SAP Trust Community,C=DE

#2 trustediss1 = CN=JD8,OU=I0020406197,OU=SAP Web AS,O=SAP Trust Community,C=DE

#3 trustedsys1 = JD8,800

#4 ume.configuration.active = true

2. com.sap.security.saml2.sp.SAML2LoginModule SUFFICIENT ok exception true Authentication Challenge due to missing credentials.

3. com.sap.engine.services.security.server.jaas.BasicPasswordLoginModule REQUISITE ok false false

4. com.sap.security.core.server.jaas.CreateTicketLoginModule OPTIONAL ok false true

Also, i've tried to add Administrator privileges to the user i'm trying to connect, but that hadn't work either. It seems that no user is reaching the server... Can't understand why...

ACL file on DTR is the default (without any permissions configured).

I then tried to switch on the SSL on NWDS but the option "File->Import->Java Cryptographic Library" isn't available on my SAP NWDS 7.3 SP05, so i can't install SSL either. I updated my NWDS to the last version, and it also doesn't appear the option.

Anyway,do you have a clue, why i can't connect to DTR using NWDS?

Any help will be appreciated

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Mar 04, 2012 at 10:16 AM

    Dear JoaoDoe ,

    Hope you are doing good.

    Do check if the below note is implemented on your server, leading to HTTPS redirection:

    SAP Note No. 973644: How to configure HTTPS redirect on J2EE Engine

    If the issue persists, run the below note and collect the traces:

    SAP Note No. 1227928 - Diagtool for troubleshooting NWDI (detailed logs)

    If HTTPS redirection is the issue, then other links should also have the same problem.

    Thank you and have a nice day :).

    _____________

    Kind Regards,

    Hemanth

    SAP AGS

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello all,

      I've discovered that the SAML configuration on my login module was the cause of the https redirection. Once i deactivated the SAML SP on my NWA, it started running without any problems on HTTP.

      I don't need SAML right now, so i can deactivate it and continue with my configurations, but i wonder how the configuration needs to be done in order to support SAML on NWDS as well.

      Hemanth thank you for the Diagtool for NWDI Note! Didn't knew this one.

      Thank you guys.

  • Mar 04, 2012 at 05:19 AM

    check with your basis to see if there is any forced https redirection.

    Add comment
    10|10000 characters needed characters exceeded